Ver Mensaje Individual
  #2 (permalink)  
Antiguo 02/09/2005, 13:12
jjvr78
Usuario no validado
 
Fecha de Ingreso: septiembre-2005
Mensajes: 6
Antigüedad: 16 años, 4 meses
Puntos: 0
Hola, eso es fácil la idea es hacer un ciclo repetitivo hasta el último número, y a medida que se lee el número se va comparando el valor leido con 2 variables llamadas MENOR y MAYOR, las cuales contendrán obviamente el valor mayor y menor de los números

Te voy a explicar con la sintáxis de pseudocódigo que manejo (las // son comentarios):

//antes que todo asumamos que ya leiste o generaste el valor de N

//Inicialmente el valor mayor es cero, es decir no existe un número mayor, por lo
//tanto al hacer la 1era comparación ese 1er número será el mayor
Mayor = 0
//Inicialmente el valor menor es un número muy grande por lo
//tanto al hacer la 1era comparación ese 1er número será el menor
Menor = 9999999999
//Se hace un ciclo repetitivo desde el 1er número hasta N
Para I=1 hasta N
//Se muestra un mensaje al usuario solicitando un número
Escribir "Indique el valor del número", I
//Se lee el número
Leer Num
//Si el valor leido es mayor que el valor almacenado
Si (Num>Mayor) entonces
//Ahora el nuevo número mayor es el leido
Mayor = Num
Fin Si
//Si el valor leido es menor que el valor almacenado
Si (Num<Menor) entonces
//Ahora el nuevo número menor es el leido
Menor = Num
Fin Si
Fin Para

Espero que haya sido de ayuda

Saludos