Ver Mensaje Individual
  #1 (permalink)  
Antiguo 12/09/2005, 14:40
Saldu
Invitado
 
Mensajes: n/a
Puntos:
Un problema con el sistema de noticias

Hola.. miren,yo estoy construyendo mi pagina web,en la que van a visitarla gente de muchos paises.Es por eso que la hago en varios idiomas,mi problema está,en que yo quiero que mi sistema de noticias,tiene que tener varios idiomas,y quiero que muestre el idioma que tenga seleccionado el usuario. Entonces,yo tengo 3 archivos,miren:

administrar.php:

Código:
<form action="procesanoticia.php" method="post">
Título noticia:<br>
<input type="text" name="titulo"><br>
Autor:<br>
<input type="text" name="autor"><br>
Categoría:<br>
<input type="text" name="categoria"><br>
Español<br>
<textarea name="noticiaspanish" cols="50" rows="10"></textarea><br>
English
<textarea name="noticiaenglish" cols="50" rows="10"></textarea><br>
French
<textarea name="noticiafrench" cols="50" rows="10"></textarea><br>
Italian
<textarea name="noticiaitalian" cols="50" rows="10"></textarea><br>
<input type="submit" value="Publicar"><br>
</form>
Ese es el archivo,en el que escribo la noticia,y la proceso en "procesanoticia.php" que es el archivo que sube todas las noticias en la bd.Como verán,tengo 4 textarea,en el que es noticiaspanish,noticiaitalian,noticiaenglish y noticiafrench,que son los idiomas que por ahora tengo en la pagina. El problema está,en que los datos los sube a la bd,pero despueés cuando los tiene que mostrar,no muestra NINGUNA noticia... osea,muestra la fecha,el autor,el titulo,pero no muestra nada en la noticia,este es el archivo ver_noticia.php:

Código:
<?php 
session_start(); 

if(!isset($_SESSION['idioma'])){ 
    $_SESSION['idioma'] = 'spanish'; 
} 

include("../lang/".$_SESSION['idioma'].".inc.php"); 


$link=mysql_connect("localhost","");
$campo="noticia".$_SESSION['idioma'];
$fila['$$campo'];
//Seleccionamos la base
mysql_select_db("tryman",$link);
$result=mysql_query("select * from noticias order by fecha ASC Limit 5",$link);
echo "
<table cellpading=2 cellspacing=1 border=0>"; 
while($row=mysql_fetch_array($result)){ 
?> 

<tr> 
<td><center><b><?php echo $row[titulo]?></b></center><br> 
</td> 
<tr> 
<td valign="justify"><?php echo $row[fecha]?></td> 
</tr> 
</tr> 
<tr> 
<td valign="justify"><? echo $fila['$$campo']; ?></td> 
</tr> 
<br>
<tr>
<td>
<font size=1 bgcolor=#FFFFFF><?php echo $row[autor]?></font>
</td>
</tr>


<?php 
} 
echo "</table>"; 

?>
Cuál es el problema? xq no muestra nada? alguien me puede ayudar? muchas gracias...