Ver Mensaje Individual
  #1 (permalink)  
Antiguo 03/07/2007, 09:27
roroland
 
Fecha de Ingreso: enero-2002
Ubicación: Mar del Plata
Mensajes: 243
Antigüedad: 16 años, 5 meses
Puntos: 0
problema insolito en firefox

Hola, quisiera por favor alguien me pueda explicar si esto es un bug del player de flash en firefox o si es mi codigo, porque no se que hacer.

Mi sitio web tiene una precarga normal que funciona sin problemas, una vez cargado el sitio arriba a la derecha hay 3 pequeñas fotos que el usuario puede seleccionar para que se carguen como imagen de fondo del sitio.

Para esto uso el mismo codigo de preloader que uso al comienzo y pese a que carga la foto el preloader no se ve, ni funciona en firefox. En IE 6 o 7 funciona perfecto, lo probe en varias computadoras y todas fallan en firefox solamente.

No entiendo pq si el preloader funciona al principio no funciona luego y si de todas formas fuera un problema de mi codigo, pq entonces funciona bien en IE ???

Aqui esta el codigo que carga las fotos:



function cargando() {
var total, cargados, porcentaje;
total = _root.prado.animacion_prado.fotonueva.getBytesTota l();
cargados = _root.prado.animacion_prado.fotonueva.getBytesLoad ed();
porcentaje = Math.floor((cargados*100)/total);
porcentaje_txt.text = porcentaje+"%";
barra_mc2.gotoAndStop(porcentaje);
if (cargados == total) {
clearInterval(hiloPrecarga);
gotoAndPlay(3);

}
}
var hiloPrecarga = setInterval(cargando, 1);
stop();


Pueden ver la diferencia si entran con ambos navegadores (firefox y IE), la direccion es: http://www.sonicbyte.com/design

Gracias