Ver Mensaje Individual
  #3 (permalink)  
Antiguo 11/01/2008, 10:32
Avatar de manyametal
manyametal
 
Fecha de Ingreso: enero-2008
Mensajes: 36
Antigüedad: 12 años
Puntos: 0
Re: AYUDA..se pierden las sesiones

gracias pero eso ya lo probe y tampoco me funciona.. Dejo un ejemplo de lo que estoy haciendo haber si me pueden ayudar

aca es donde $_SESSION['usuario'] no existe y nunca puedo ver la pagina
index.php
Código PHP:
<?php
session_start
();
if (isset(
$_SESSION['usuario'])){
?> 
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<title>Untitled Document</title>
</head>

<body>
<?php
echo "Se puede ver la pagina, esta registrado";

}else{
echo 
"No esta registrado";
}
?>
</body>
</html>
login.php
Código PHP:
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<
html xmlns="http://www.w3.org/1999/xhtml">
<
head>
<
meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
<
title>Untitled Document</title>
</
head>

<
body>
<
form name="formulario" action="s_login.php" method="post">
<
table>
<
TR
          <
TD width="32%" bordercolor="#FCFCFC" bgColor=#4F4F4F><span class="style2"><FONT 
      
face="Times New Roman, Times, serif"Usuario</FONT></span></TD>
        </
TR>
         <
TR>
           <
TD bgColor=#cccccc><INPUT id=usuario maxLength=30 size=20 name=usuario class="textbox" /></TD>
        
</TR>
        
          <
TR
          <
TD width="32%" bgColor=#4f4f4f><span class="style2"><FONT 
      
face="Times New Roman, Times, serif" >Contraseña</FONT></span></TD>
        </
TR>
         <
TR>
           <
TD bgColor=#cccccc><INPUT id=pass maxLength=15 size=20 name=pass type="password" class="textbox"></TD>
        
</TR>
      </
TBODY>
    </
TABLE>
        <
P>
      <
input id=ingresar type=submit value=Ingresar name=ingresar/>
      </
P>
      </
form>
      
</
body>
</
html
s_login.php
Código PHP:
<?php

session_start
();
$usuario=$_POST['usuario'];
$pass=$_POST['pass'];

login($usuario$pass);

function 
login($usuario$pass){
$usu =0;
$eliminado=0;
$link mysql_connect("localhost""root","root");
mysql_select_db("bali",$link);
// Primeros comprobamos el usuario.
$consultaUsuariomysql_query("SELECT * FROM usuarios where nombre= '".$usuario."' and login= '".$pass."' and eliminado= '".$eliminado."' " $link);
//Para saber si existe usuario
while($rowmysql_fetch_assoc($consultaUsuario)) {
$usu 1;
}

if(
$usu == 1) {
$_SESSION['usuario']= $usuario;
echo 
$_SESSION['usuario']; 
header("Location:index.php");

}else{
echo 
"Usuario o contraseña incorrectos"
header("Location:login.php");
}

}
?>
vi ejemplos muy similares que parecen funcionar, capaz que es un problema con la configuracion o no se que podra ser...