Ver Mensaje Individual
  #1 (permalink)  
Antiguo 26/02/2008, 05:22
xana1968
 
Fecha de Ingreso: febrero-2008
Mensajes: 25
Antigüedad: 10 años, 7 meses
Puntos: 1
Podeis ayudarme con un Preolader?

Hola buenos dias y gracias a todos/as.
Os cuento por encima, tengo hecho un swf que va a ser mi presentación, en un principio hice 2 escenas, pero al final las he refundido en 1 sola.
Las tres primeras capas, son lo que llamamos el proelader, la típica barra y el texto del procentaje, y la otra con las acciones.
Luego en el fotograma 3, ya es donde empieza mi presentación.
Mi problema es que cuando le doy para ver cómo quedaría publicada y pincho "simular carga", la barrita coriendo y el porcentaje se ven mu bien, es más se ve que funciona, sin embargo, cuando ya le doy publicación, el el fichero html o swf no se ve nada, pasa directamente a la película.
No sé si es que ocupa poco o que, según los datos de publicación son 67 kb, el codigo que he puesto es el siguiente:
stop();
loadingBar._xscale = 1;
var loadingCall:Number = setInterval(preloadSite, 50);
function preloadSite():Void {
var siteLoaded:Number = _root.getBytesLoaded();
var siteTotal:Number = _root.getBytesTotal();
var percentage:Number = Math.round(siteLoaded/siteTotal*100);
loadingBar._xscale = percentage;
percentClip.percentDisplay.text = percentage + "%";
percentClip._x = loadingBar._x + loadingBar._width;
if (siteLoaded >= siteTotal) {
clearInterval(loadingCall);
gotoAndplay(10);
}
}
Como os digo funcionar funciona, pq se ve como corre la barra y el porcentaje aumenta, sin embargo cuando ya lo paso a internet, o lo inserto en dreamweaver no se ve.
¿Podeis ayudarme?
GRACIAS