Ver Mensaje Individual
  #1 (permalink)  
Antiguo 07/03/2009, 13:06
rodrigo_00
 
Fecha de Ingreso: noviembre-2007
Ubicación: Lanus, Buenos Aires
Mensajes: 178
Antigüedad: 13 años, 5 meses
Puntos: 14
Problema con zend_cache y regexps

Hola a todos!

tengo un problema, a ver si alguien me puede decir que estoy haciendo mal

tengo Zend_Cache configurado de la siguiente manera

Código PHP:
 $frontendOptions = array(
           
'lifetime' => 7200,
           
'debug_header' => true// for debugging
           
'regexps' => $regexps_cache_config,
           
'default_options' => array(
                
'make_id_with_cookie_variables' => true,
                
'cache_with_cookie_variables' => true,
                
'cache_with_session_variables' => true,
                
'cache_with_post_variables' => false
            
)
        );

        
$backendOptions = array(
            
'cache_dir' => 'tmp/zend_cache'
        
);

        
$cache Zend_Cache::factory('Page''File'$frontendOptions$backendOptions);
        
$cache->start(); 

donde $regexps_cache_config contiene las urls que deben ser cacheadas, pero el problema es que me cachea todo todo todo :S no tendria que cachear solo las urls que "matchean" las expresiones regulares??

otra cosa que me sorprendio, es que hace unas horitas lo probe y funcionaba bien cacheando solo las paginas que yo quiero, porque pudo haber dejado de funcionar? me estoy olvidando de configurar algo?? :S

otro problema que tuve es que recien mostraba el contenido cacheado 2 veces, lo solucione borrando cookies y cache del navegador, pero eso no deberia pasar no? :P

bueno si alguien me puede dar alguna ayudita estare agradecido jaja

saludos!!