Ver Mensaje Individual
  #1 (permalink)  
Antiguo 13/05/2010, 12:39
dariocasanova
 
Fecha de Ingreso: julio-2004
Mensajes: 19
Antigüedad: 15 años, 7 meses
Puntos: 0
Exclamación Problema con Simplexml+XML+Atributos

BUenas.. paso a contarles mi problema por segunda vez (tarde tanto la primera que me expiro la sesion):
Probe toda clase de ejemplos satisfactoriamente pero no logro adaptarlos.
Tengo una galeria en flash que lee datos de un XML. Esta es la estructura del archivo:
Código:
<items>
	<item filename="thumnail1.jpg" url="imagen1.jpg" title="tit" description="desc"/>
	<item filename="thumnail2.jpg" url="imagen2.jpg" title="tit" description="desc"/>
</items>
A su vez cuando hago click en la minuatura se me abren con lightbox (el [URL="http://www.huddletogether.com/projects/lightbox2/#how"]link[/URL] para el que no lo conoce)
Logro que se abra cada imagen individualmente, lo uqe no puedo hacer es que el lIghtbox me cree una "galeria" puesto que me pide que exista en el htm para cada foto lo siguiente:

Código:
<a href="images/image-1.jpg" rel="lightbox[roadtrip]">image #1</a>
<a href="images/image-2.jpg" rel="lightbox[roadtrip]">image #2</a>
<a href="images/image-3.jpg" rel="lightbox[roadtrip]">image #3</a>
Me propuse generar eso mismo con php y ahi vienen los problemas. El priemero es que no se casi nada de php. El segundo es que lo siguiente no me funciona:

Código:
<?php

$xml = simplexml_load_file("lista.xml");


foreach ($xml->items[0]->item as $item) {

     echo "<a href=" ;
     echo $item['url'];
     echo "rel='lightbox[galeria1]'>image #1</a>";
    
}
?>
Pasando por un sinfin de errores el ultimo que me muestra es : Warning: Invalid argument supplied for foreach()

Algun alma caritatita ruego me ayude con este Frankenstein al que le falta un pedacito nomas para salir caminando jejje
Gracias de antemano
Saludosa todos
(Ctrl+C por las dudas)