Ver Mensaje Individual
  #1 (permalink)  
Antiguo 08/07/2010, 09:26
Monty_77
 
Fecha de Ingreso: marzo-2010
Mensajes: 13
Antigüedad: 8 años, 8 meses
Puntos: 0
Problemas para validar en w3c

Hola gente.

tengo el siguiente link en una pagina y me tira errores al validar:

<a href="inicio.php?edicion=<?php echo($ultima_edicion);?>&seccion=ultima_edicion">C lick aqui para ver la ultima edicion</a>

Me informa de errores con el "&" (ampersand) que une las dos variables que pasa el link.

La verdad que no veo el error, incluso en la pagina hay otros links similares y validaron correctamente.



El informe del validador es el siguiente:
a href="inicio.php?edicion=2&seccion=ultima_edicion" >

An entity reference was found in the document, but there is no reference by that name defined. Often this is caused by misspelling the reference name, unencoded ampersands, or by leaving off the trailing semicolon (;). The most common cause of this error is unencoded ampersands in URLs as described by the WDG in "Ampersands in URLs".

Entity references start with an ampersand (&) and end with a semicolon (;). If you want to use a literal ampersand in your document you must encode it as "&amp;" (even inside URLs!). Be careful to end entity references with a semicolon or your entity reference may get interpreted in connection with the following text. Also keep in mind that named entity references are case-sensitive; &Aelig; and &aelig; are different characters.

If this error appears in some markup generated by PHP's session handling code, this article has explanations and solutions to your problem.

Note that in most documents, errors related to entity references will trigger up to 5 separate messages from the Validator. Usually these will all disappear when the original problem is fixed.




desde ya muchas gracias!