Ver Mensaje Individual
  #1 (permalink)  
Antiguo 29/07/2011, 18:13
helenp
 
Fecha de Ingreso: mayo-2009
Mensajes: 382
Antigüedad: 10 años, 7 meses
Puntos: 6
problema utf-8

Hola,
he estado cambiando parte de mi web que estaba en iso-8859-1 a utf-8.
Cambié todos los includes etc, excepto la base de datos y al ver que el formulario me mandaba los carácteres mal en el email decidí hacer un formulario sencillo sin otra cosa en la página.

El host ofrece esta cgi y hice un formulario utf-8 sencillo.
Este es la pàgina entera:
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">
<html>
<head>
<title>Untitled Document</title>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8">
</head>

<body>
<FORM ACTION="http://midominio.com/cgi-sys/FormMail.cgi" METHOD="POST" accept charset="UTF-8">
<input type=hidden name="recipient" value="[email protected]">
<input type=hidden name="subject" value="Asunto del mail que se envia">

<table border="0" cellspacing="2" cellpadding="2">
<tr>
<td><font face="Verdana, Arial, Helvetica, sans-serif" size="2">Nombre:<br>
<input type="text" name="nombre" size="25" maxlength="300">
</font></td>
<td> <font face="Verdana, Arial, Helvetica, sans-serif" size="2">Email:<br>
<input type="text" name="email" size="25" maxlength="300">
</font></td>
</tr>
<tr>
<td colspan="2">
<div align="center"><br>
<input type="submit" value="Enviar">
</td>
</tr>
</table>
</form>
</body>
</html>

Lo raro es que en firefox, rellenaba el formulario y le daba a enviar, salía una página del cgi diciendo:
Form Submission Results
nombre: cañon guía åäö
perfecto justo lo que había escrito, sin embargo el email la recibí asi:
nombre: cañon guÃ*a åäö

Hago la misma prueba con Chrome y con ie, y allí sale hasta los carácteres mal en la página de resultado de cgi....

No veo como yo pueda hacer algo mal, puede ser problemas del host, o que la página cgi no esta en utf-8???
Tambien hice sencillos formularios un utf-8 de esos que escribes en el formulario y se te abre la ventana de outlook para enviar lo que has escrito y me salía los caracteres mal......

No entiendo nada,
ayuda please.
Gracias,
Helena