Ver Mensaje Individual
  #4 (permalink)  
Antiguo 08/08/2011, 18:14
Avatar de HackmanC
HackmanC
 
Fecha de Ingreso: enero-2008
Ubicación: Guatemala
Mensajes: 1.817
Antigüedad: 11 años, 10 meses
Puntos: 260
Sonrisa Respuesta: class file has wrong version

Hola,

Cita:
Iniciado por HaX Ver Mensaje
gracias hackamanc, hice lo q me dijiste, actualize el jdk del 1.4 al 1.6.0.26
pero sabes, el problemas sigue....
El problema es que estas usando una versión antigua de JDeveloper.
¿Acerté con lo de JDeveloper? Google oracle.com

Lo que quise dar a entender es: asegúrate, sin lugar a dudas, que estas usando una versión de Java mas reciente, sin importar que fabricante o herramienta estés usando, si esa herramienta no permite actualizar o usar un compilador javac mas nuevo, actualiza la herramienta para ver si lo permite, sino lo permite, cambia a una herramienta que permita usar cualquier compilador mas nuevo.

El compilador de Oracle muestra estos mensajes de error cuando intentas usar una clase mas nueva (JDK7) con un compilador mas antiguo:

JDK 6
warning: .\V6.class: major version 51 is newer than 50, the highest major version supported by this compiler.

JDK 5
class file has wrong version 51.0, should be 49.0

JDK 4
class file has wrong version 51.0, should be 48.0

JDK 3
class file has wrong version 51.0, should be 47.0

Ves la similitud del problema?
Saludos,