Ver Mensaje Individual
  #5 (permalink)  
Antiguo 16/11/2011, 16:33
dandarway
 
Fecha de Ingreso: mayo-2010
Mensajes: 38
Antigüedad: 9 años, 2 meses
Puntos: 0
Respuesta: Actualizar a ultima version de PHP

He estado investigando un poco acerca del tema...
He dado con una serie de links que me han ayudado un poco a comprender el problema:
http://www.simmonsconsulting.com/200...er-to-php-528/
https://help.ubuntu.com/community/Re...es/CommandLine
http://doc.ubuntu-es.org/Apt

En estos momentos tengo la siguiente información en mi "sources.list":
Código:
deb http://archive.ubuntu.com/ubuntu hardy main restricted universe
deb http://archive.ubuntu.com/ubuntu hardy-updates main restricted universe
deb http://archive.ubuntu.com/ubuntu hardy-security main restricted universe

## This is a temporary appended by Autoinstaller for
## specify source of product's packages for APT.
deb http://autoinstall.plesk.com/ubuntu/PSA_9.5.3 hardy all
NOTA: es posible que contenga algún error ya que lo he tenido que transcribir.

De esos repositorios, sólo se puede extraer la version 5.2.4-2ubuntu5 (la que tengo). Por tanto, aunque actualice no podré obtener una versión superior de la que ya tengo.

Entonces me imagino que el problema reside en encontrar un repositorio de confianza que ofrezca la versión de PHP que busco. Por ejemplo:
Código:
deb http://ppa.launchpad.net/tarkus/ubuntu hardy main
deb-src http://ppa.launchpad.net/tarkus/ubuntu hardy main
Estos repositorios tienen la versión 5.2.10, que no es la busco pero ya nos estamos acercando.
He encontrado a gente que dice haber instalado php 5.3.5 desde aqui:
http://www.dotdeb.org/category/php/
Pero parece que alli se encuentren repositorios para Debian, no Ubuntu.

En fin, menudo quebradero de cabeza para alguien que desconocía completamente este mundo.

Alguien puede arrojar algo de luz?

Gracias!