Ver Mensaje Individual
  #1 (permalink)  
Antiguo 14/02/2012, 17:43
GoldFran
 
Fecha de Ingreso: mayo-2007
Mensajes: 237
Antigüedad: 15 años, 3 meses
Puntos: 3
Problema en el CMS e-learning Moodle (PHP)

Buenas

Estoy certificándome en instalación, gestion, administración y resolución de problemas en aulas virtuales tipo moodle pero tengo un par de problemas, primero por partes:

Problema con una extensión int en PHP:

En la instalación se me advierte que la extensión intl no está instalada o activada, y es recomendable para el tema de los multilenguajes... fui al archivo de configuración PHP y configuré extension=php_intl.dll (más bien quité el ";" para que se active)... Pues bien, me pedía activar más extensiones pero todas se activan quitando el ";" excepto esta intl.dll

¿Que puede estar pasando, me hará falta una librería? Si es así ¿Cómo conseguirla

Problema con la ubicación del directorio Moodle

Bien, Cuando intento acceder desde otro equipo me canta que es imposible puesto que no encuentra localhost/moodle... Indagando un poco entré en config.php de moodle y edité esta línea

Código PHP:
$CFG->wwwroot 'http://192.168.1.16/moodle'


He sustituido localhsot por la IP que veis y ahora si funciona en la intranet, pero claro... que pasa si lo ejecuto en local? Pues que no funciona porque dice que solo funciona haciendolo desde la IP

Seguramente es que o no me acuerdo de programar en PHP o sencillamente no se pueden tener dos rutas... Porque en local no tiene sentido que lo haga con la IP propia... he intentado añadir con , con . con -... pero nada

Código PHP:
$CFG->wwwroot 'http://192.168.1.16/moodle''http://localhost/moodle' 
vamos que algo así no funciona ...

¿Alguna sugerencia?

PD: software

- Windows 2008 Server Standard ENG x64
- EasyPHP 5.3.9 si no recuerdo mal, vamos el útlmo estable

Saludos y gracias :)