Ver Mensaje Individual
  #1 (permalink)  
Antiguo 29/04/2012, 04:00
roncco
 
Fecha de Ingreso: abril-2012
Mensajes: 63
Antigüedad: 10 años, 3 meses
Puntos: 2
jquery: background image, explorer y su madre

Pues resulta que cuando creí tener mi web casi acabada, decido ver cómo quedaría en ese huevo frito virtual llamado internet explorer, y entre otras atrocidades -he visto cosas que no creeríais- hay una que no consigo resolver.

Veréis, tengo unos botones para formularios que hice yo. Creé dos imágenes, una de las cuales es para cuando el botón se pulsa. Es algo tan sencillo como cuando se hace click en un botón se carga la segunda imagen. Pues esto, que funciona a la primera en firefox, en explorer no hay manera.

Os pongo los retales de código. Primero el php:

Código PHP:
Ver original
  1. <div class="crearBuscarFicha">
  2.  
  3. <form class="formularioLateral" action="." method="post">
  4.  <label for="nombreProducto">Crear Ficha:</label><br />
  5.  <input type ="text" class="campoFormularioLateral" size="19" name="nombreProducto" id="nombreProducto" /><br />
  6.  <input type="submit" class="botonFormulario" name="crearFicha" value="Crear" />
  7.  
  8.  </form>
  9. </div>

Luego el css:

Código CSS:
Ver original
  1. .botonFormulario{
  2.     margin-top: 15px;
  3.     background: #c1dbc2 url(/imagenes/web/botonEnviar.png) no-repeat center center;
  4.     width: 79px;
  5.     height: 37px;
  6.     border-bottom: 2px solid grey;
  7.  
  8. }

Y por último el jquery:

Código Javascript:
Ver original
  1. $('.botonFormulario').click(function(){
  2. $(this).css({"background":"#c1dbc2 url(/imagenes/web/botonEnviarActivado.png) no-repeat center center"});
  3. });

¿Alguien me puede echar una mano?