Ver Mensaje Individual
  #1 (permalink)  
Antiguo 25/02/2014, 05:47
xasgay
 
Fecha de Ingreso: junio-2013
Mensajes: 18
Antigüedad: 8 años, 2 meses
Puntos: 0
Problema con urlencode y base64

Tengo un pequeño problema y es que desencripta bien el enlace, pero a la hora de meterlo en un href, este muestra estos simbolos: "�" y no se por que me pasa esto.
Bueno, os dejo aqui una demo, para que mireis lo que pasa:


http://prueba.fast-page.org/demo/des.php?cadena=Rw%2Bt5%2BDUkjWuQE5LhUUR9tvBHYo%2Bq O3H5VRp8UhDC%2B0%3D


Vereis que la palabra desencriptada es: " http://www.google.es/ " pero a la hora de meterlo en un href, este se vuelve loco :S
Espero respuestas, gracias desde ya

EDITO: Dejo el código fuente
Código PHP:
Ver original
  1. <html>
  2. <head>
  3. <meta charset="utf-8" />
  4. </head>
  5. <body>
  6. <form action="#" method="get">
  7. <input type="hidden" name="cadena" size="60" />
  8. </form>
  9.     <?php
  10.     $contrasena = "hello";
  11.     function desencriptar($cadena, $clave){
  12.         $cadena=base64_decode($cadena);
  13.         $cifrado = MCRYPT_RIJNDAEL_256;
  14.         $modo = MCRYPT_MODE_ECB;
  15.         $resultado= mcrypt_decrypt($cifrado, $clave, $cadena, $modo,
  16.             mcrypt_create_iv(mcrypt_get_iv_size($cifrado, $modo), MCRYPT_RAND));
  17.         return $resultado;
  18.     }
  19.    
  20.    
  21.             $valorOriginal = desencriptar($_GET['cadena'], $contrasena);
  22.             echo "Texto Desencriptado: <code style='color:#009922;'>".$valorOriginal."</code>";
  23.             echo '<br>';
  24.             echo '<a href="'.$valorOriginal.'">Enlace de Prueba</a>';
  25.    
  26.     ?>
  27. </body>
  28. </html>