Ver Mensaje Individual
  #1 (permalink)  
Antiguo 22/05/2015, 06:47
GatoLopeZ90
 
Fecha de Ingreso: abril-2015
Ubicación: Madrid
Mensajes: 1
Antigüedad: 4 años, 9 meses
Puntos: 0
Fallo en las consultas o base de datos

Buenos días. Es mi primer post, y mi primer mensaje, he utilizado muchas veces vuestro foro y siempre he encontrado respuesta pero a esto no lo he encontrado, de ahí que lo cree.

Tengo este script de conexion a mi base de datos:

<?php
$host_name = "localhost:/tmp/mysql5.sock";
$database = "db549047380";
$user_name = "dbo549047380";
$password = "****";
$mysqlsocket = "/tmp/mysql5.sock";
$conexion = mysqli_connect($host_name, $user_name, $password, $database,$mysqlsocket);
if (mysqli_connect_errno()){
echo "Error al conectar con servidor MySQL: " . mysqli_connect_error();
}else{
echo 'YEEEEEEEEE';
}
?>

El problema es que supuestamente llego a conectar a la base de datos, ya que yo leo el "YEEEEEEEEEE" y eso es que no le da error la funcion de mysqli, pero no me aparece ningún dato de los que tengo en la base de datos, aparece la página vacia, y no son fallos de las consultas, ya que cuando trabajaba con otra base de datos funcionaba sin problemas.

Espero vuestra ayuda, ya que la necesito. Muchas gracias.

P.D: He probado funciones que hacen ping a la base de datos. Este en cuestión ha sido la que utilizé:

if (mysqli_ping($conexion)) {
printf ("Our connection is ok!\n");
} else {
printf ("Error: %s\n", mysqli_error($conexion));
}

Me aparece "Error :" pero no muestra ningún error.

Última edición por GatoLopeZ90; 22/05/2015 a las 06:52