Foros del Web » Programando para Internet » Ruby »

problema con la gema rake

Estas en el tema de problema con la gema rake en el foro de Ruby en Foros del Web. saludos, resulta que hace poco instale la ultima version de rails (3.0.7) pero tengo problemas al hacer: Código: rake db:migrate ya que segun leo, es ...
  #1 (permalink)  
Antiguo 30/05/2011, 00:22
Avatar de exactlimon  
Fecha de Ingreso: mayo-2009
Ubicación: Pereira, Colombia
Mensajes: 42
Antigüedad: 11 años, 5 meses
Puntos: 0
problema con la gema rake

saludos, resulta que hace poco instale la ultima version de rails (3.0.7)

pero tengo problemas al hacer:
Código:
rake db:migrate
ya que segun leo, es problema de la version 0.9.0 de la gema rake, y segun leo se debe usar la version 0.8.7

en muchos lugares he leido que toca editar el gemfile y poner esto:
Código:
gem 'rake', '0.8.7'
pero señores... no se cual es el gemfile, en un sitio encontre que era en la raiz de la carpeta rails, pero alli no lo encontre.

si alguno de ustedes ha podido solucionar esto, le agradeceria que compartiera su conocimiento.
  #2 (permalink)  
Antiguo 30/05/2011, 00:33
Avatar de exactlimon  
Fecha de Ingreso: mayo-2009
Ubicación: Pereira, Colombia
Mensajes: 42
Antigüedad: 11 años, 5 meses
Puntos: 0
Respuesta: problema con la gema rake

despues de leer me di cuenta que estaba buscando en el lugar equivocado,
el archivo gemfile se encuentra en la raiz del directorio del projecto web que cree.

:( espero servirle de ayuda a gente que esté iniciandose en rails
  #3 (permalink)  
Antiguo 30/05/2011, 14:58
Avatar de jam666  
Fecha de Ingreso: septiembre-2009
Ubicación: Isla De Margarita - Venezuela
Mensajes: 428
Antigüedad: 11 años
Puntos: 39
Respuesta: problema con la gema rake

Hace un rato tuve ese mismo problema, ejecutando bundle install en una aplicación se me instalo Rake 0.9.0 (yo tenia 0.8.7) y este empezó a dar problemas. por el momento lo solucione desinstalando Rake 0.9.0 ya que es la que tiene el problema y me quede con Rake 0.8.7.

En GitHub dan una solución diferente quedandote con 0.9.0, pero no lo he probado.
__________________
J.A.M
Jam Blog

Etiquetas: rake
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 15:49.