Foros del Web » Programación » Ruby »

Problema con ruby on rails en Ubuntu 12.10 y windows 7

Estas en el tema de Problema con ruby on rails en Ubuntu 12.10 y windows 7 en el foro de Ruby en Foros del Web. hola amigos espero me puedan ayudar. actualmente estoy trabajando ruby on rails en windows 7 pero tuve problema para integrar ruy on rails con bootstrap ...
  #1 (permalink)  
Antiguo 22/04/2013, 23:11
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.595
Antigüedad: 4 años, 2 meses
Puntos: 6
Problema con ruby on rails en Ubuntu 12.10 y windows 7

hola amigos espero me puedan ayudar.

actualmente estoy trabajando ruby on rails en windows 7 pero tuve problema para integrar ruy on rails con bootstrap como se indica en este videotutorial http://railscasts.com/episodes/328-t...view=asciicast , no veo instaldas las dependencias libv8 y less-rails , con este problema decidi trabajar en ubuntu 12.10 pero observo que no esta funcionando de la mejor manera por que al momento de crear un nuevo proyecto no esta creando todos los archivos

montes@montes-VirtualBox:~/Escritorio/RoR$ rails store
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
/usr/lib/ruby/vendor_ruby/railties/lib/rails_generator/generators/applications/app/app_generator.rb:7: Use RbConfig instead of obsolete and deprecated Config.

y despues al intentar crear el scaffold sale esto:

montes@montes-VirtualBox:~/Escritorio/RoR$ rails g scaffold product name price:decimal --skip-stylesheets
/usr/lib/ruby/1.9.1/rubygems/custom_require.rb:36:in `require': iconv will be deprecated in the future, use String#encode instead.
/usr/lib/ruby/vendor_ruby/railties/lib/rails_generator/generators/applications/app/app_generator.rb:7: Use RbConfig instead of obsolete and deprecated Config.
invalid option: --skip-stylesheets
  #2 (permalink)  
Antiguo 27/04/2013, 02:09
Avatar de pzin
Moderatoren
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 9.436
Antigüedad: 12 años, 3 meses
Puntos: 1729
Respuesta: Problema con ruby on rails en Ubuntu 12.10 y windows 7

¿Qué versión de Rails estás usando? Igual el problema que tienes es ese, porque si estás usando Ruby 1.9.1, no puedes usar por ejemplo la última versión de rails.
  #3 (permalink)  
Antiguo 27/04/2013, 11:00
 
Fecha de Ingreso: septiembre-2010
Mensajes: 1.595
Antigüedad: 4 años, 2 meses
Puntos: 6
Respuesta: Problema con ruby on rails en Ubuntu 12.10 y windows 7

pzin gracias por responder estoy utilizando ruby 1.9.3 p374 y la version de rails es 4.0.0.beta1
RubyGems version 2.0.3
  #4 (permalink)  
Antiguo 28/04/2013, 02:44
Avatar de pzin
Moderatoren
 
Fecha de Ingreso: julio-2002
Ubicación: Islas Canarias
Mensajes: 9.436
Antigüedad: 12 años, 3 meses
Puntos: 1729
Respuesta: Problema con ruby on rails en Ubuntu 12.10 y windows 7

Según el error, estás usanso la versión 1.9.1 y la versión beta de Rails 4 requiere de al menos Ruby 1.9.3, aunque recomiendan Ruby 2.

De todas formas, yo no me metería a usar la primera versión beta de cualquier cosa. Antes de Agosto-Septiembre no sacarán una versión estable de Rails 4.

Aunque igual el error viene por aquí: Después de crear la aplicación, tienes que moverte hasta la aplicación y ejecutar el scaffold desde ahí, por ejemplo:

Código BASH:
Ver original
  1. rails new store
  2. cd store
  3. rails generate scaffold...

Etiquetas: rubyonrails
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:22.
SEO by vBSEO 3.3.2