Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » WordPress »

Error de carga

Estas en el tema de Error de carga en el foro de WordPress en Foros del Web. Buenas tardes, Tengo una página montada en WP desde hace años y es la primera vez tras actualizar unas imágenes ha dejado de funcionar. No ...
  #1 (permalink)  
Antiguo 13/01/2020, 07:10
Avatar de ken_masters  
Fecha de Ingreso: febrero-2005
Mensajes: 422
Antigüedad: 14 años, 11 meses
Puntos: 5
Error de carga

Buenas tardes,

Tengo una página montada en WP desde hace años y es la primera vez tras actualizar unas imágenes ha dejado de funcionar. No he tocado ningún otro archivo ni nada del ‘theme’. ¿Alguien tiene idea de qué ha podido ocurrir?

Adjunto captura de lo que muestra el navegador.



Cuando entro al back end de mi página, en mi panel de usuario de WP, también aparece el mismo texto:

scription_walker::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0) in /usr/home/dominio.com/web/cat/wp-content/themes/nebula/lib/functions/support_function.php on line 28 Warning: Parameter 1 to wp_default_styles() expected to be a reference, value given in /usr/home/dominio.com/web/cat/wp-includes/plugin.php on line 601 Warning: Parameter 1 to wp_default_scripts() expected to be a reference, value given in /usr/home/dominio.com/web/cat/wp-includes/plugin.php on line 601
__________________
Here comes a new challenger?

Última edición por ken_masters; 13/01/2020 a las 07:40
  #2 (permalink)  
Antiguo 13/01/2020, 09:44
Avatar de ArturoGallegos
Moderador
 
Fecha de Ingreso: febrero-2008
Ubicación: Morelia, México
Mensajes: 6.598
Antigüedad: 11 años, 10 meses
Puntos: 1101
Respuesta: Error de carga

Seguramente tenias una versión muy vieja en tu wordpress y hosting, lo has actualizado y hay partes que no son compatibles.

Como dice el error tendrás que corregir el código PHP de tu template para hacerlo compatible, el mismo error te menciona en que archivo y linea comenzar a buscar.
  #3 (permalink)  
Antiguo 13/01/2020, 10:32
Avatar de ken_masters  
Fecha de Ingreso: febrero-2005
Mensajes: 422
Antigüedad: 14 años, 11 meses
Puntos: 5
Respuesta: Error de carga

Cita:
Iniciado por ArturoGallegos Ver Mensaje
Seguramente tenias una versión muy vieja en tu wordpress y hosting, lo has actualizado y hay partes que no son compatibles.

Como dice el error tendrás que corregir el código PHP de tu template para hacerlo compatible, el mismo error te menciona en que archivo y linea comenzar a buscar.
Muy bien, tengo que abrir el archivo, y en la linea que especifica corregir el error. Mmmm, ¿podría postearlo aquí para que le eches un vistazo? Dudo que yo sepa detectarlo.
__________________
Here comes a new challenger?
  #4 (permalink)  
Antiguo 13/01/2020, 11:13
Avatar de ArturoGallegos
Moderador
 
Fecha de Ingreso: febrero-2008
Ubicación: Morelia, México
Mensajes: 6.598
Antigüedad: 11 años, 10 meses
Puntos: 1101
Respuesta: Error de carga

Claro publicalo y vemos si hay algo a simple vista,





Aunque te adelanto que seguramente eso requiere mas que un vistazo, no es como abrir el archivo y borrar un dígito, debes revisar a fondo que es lo que hace como lo hace y corregir en consecuencia.

Es algo que debes considerar basándote en tu versión de wordpres, versión de PHP y características de tu hosting.

Recuerda dar una leida a la documentacion sobre Walker_Nav_Menu
Cita:
scription_walker::start_el(&$output, $item, $depth, $args) should be compatible with Walker_Nav_Menu::start_el(&$output, $item, $depth = 0, $args = Array, $id = 0)



La zona horaria es GMT -6. Ahora son las 08:30.