Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » WordPress »

En localhost OK, pero wordpress no me carga los estilos css desde otras computadoras

Estas en el tema de En localhost OK, pero wordpress no me carga los estilos css desde otras computadoras en el foro de WordPress en Foros del Web. Tengo un blog en localhost y estoy trabajando ahora en el diseño del mismo, pero necesito ver como se ve desde otras computadoras en la ...
  #1 (permalink)  
Antiguo 30/06/2010, 12:12
Avatar de rogertm
Mod->Cuba
 
Fecha de Ingreso: julio-2005
Ubicación: /home/Cuba/Habana/rogertm/
Mensajes: 2.922
Antigüedad: 13 años, 10 meses
Puntos: 638
En localhost OK, pero wordpress no me carga los estilos css desde otras computadoras

Tengo un blog en localhost y estoy trabajando ahora en el diseño del mismo, pero necesito ver como se ve desde otras computadoras en la red LAN que tenemos en la oficina, para en algún momento mostrárselo a los jefes y vean como va el trabajo y más adelante hacer pruebas de introducción de post desde esta red, pero no me carga los estilos css...

Lo curioso es que me sucede con cualquier blog que tenga en mi servidor local e intente ver desde otra computadora y desde mi compu, puedo ver sin problemas lo mismo accediendo como http://localhost/ o http://xx.xx.xx.xx/ con el IP de la máquina (NO 127.0.0.1)

¿Cuál puede ser el problema?

Saludos, gracias de antemano...

EDITO: Estoy usando wordpress 2.9.2
__________________
Friki y Blogger por Cuenta Propia:213
Twenty'em: Theming is Prose

Última edición por rogertm; 30/06/2010 a las 12:17
  #2 (permalink)  
Antiguo 30/06/2010, 18:56
 
Fecha de Ingreso: septiembre-2008
Ubicación: Lanzarote, Canarias
Mensajes: 486
Antigüedad: 10 años, 9 meses
Puntos: 41
Respuesta: En localhost OK, pero wordpress no me carga los estilos css desde otras co

Lógicamente el problema es que al instalar el wordpress pones la dirección de localhost, y wordpress te pone esa url en el css etc... por eso los demas no lo pueden ver y tu si... ¿solución? utilizar un subdominio no-ip y cambiar la url desde el wp-admin.
  #3 (permalink)  
Antiguo 30/06/2010, 18:58
Avatar de alexk
Colaborador
 
Fecha de Ingreso: julio-2009
Ubicación: De vuelta al trono
Mensajes: 1.697
Antigüedad: 9 años, 11 meses
Puntos: 137
Respuesta: En localhost OK, pero wordpress no me carga los estilos css desde otras co

para eso deberias usar rutas relativas (../css/style.css) enves de rutas absolutas (http://...)
------------------
Edito:
ups ni caso... mejor #2
__________________
Temas para wordpress.

Última edición por alexk; 30/06/2010 a las 19:04 Razón: ups
  #4 (permalink)  
Antiguo 01/07/2010, 06:37
Avatar de rogertm
Mod->Cuba
 
Fecha de Ingreso: julio-2005
Ubicación: /home/Cuba/Habana/rogertm/
Mensajes: 2.922
Antigüedad: 13 años, 10 meses
Puntos: 638
Respuesta: En localhost OK, pero wordpress no me carga los estilos css desde otras co

Pues eso he hecho, he cambiado la dirección del Blog en el administrador y he puesto la IP de la máquina y todo va muy bien...

Thnx...
__________________
Friki y Blogger por Cuenta Propia:213
Twenty'em: Theming is Prose
  #5 (permalink)  
Antiguo 11/10/2013, 00:56
 
Fecha de Ingreso: abril-2013
Mensajes: 2
Antigüedad: 6 años, 2 meses
Puntos: 0
Pregunta Respuesta: En localhost OK, pero wordpress no me carga los estilos css desde otras co

me sumo al tema, hola, aun soy un poco novato en esto de los sitios web, quise ver el sitio en la red LAN, puse la ip de mi computador que esta haciendo de servidor local en

Ajustes generales > Dirección de WordPress (URL) y Dirección de sitio (URL)


me cargan los estilos pero no las imágenes.


codig0 con eso de poner un subdominio no-ip , ¿puedes darme un ejemplo para entenderlo mejor?. saludos

Última edición por redxkid; 11/10/2013 a las 01:05
  #6 (permalink)  
Antiguo 11/10/2013, 15:06
Avatar de ArturoGallegos
Moderador
 
Fecha de Ingreso: febrero-2008
Ubicación: Morelia, México
Mensajes: 6.358
Antigüedad: 11 años, 3 meses
Puntos: 1042
Respuesta: En localhost OK, pero wordpress no me carga los estilos css desde otras co

hola @redxkid bienvenido al foro,

supongo tu problema son imágenes colocadas en los post y paginas, esto se debe a que cada que creas contenidos la url completa se guarda en la base de datos, por lo que ya no es suficiente cambiar la url del blog también tendrás que ir a la base de datos a actualizar todas las url de imágenes, o bien editar cada pagina y contenido de tu sitio.

Nota:
Por favor abstente en el futuro de hacer preguntas sobre tus problemas en los temas de otros, por muy similares que sean los problemas te sugerimos que habrás un nuevo tema.
Si con lo que te dije no solventas tu problema habré un nuevo tema, no lo continúes en este.

Etiquetas: carga, computadoras, css, estilos, localhost
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:00.