Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » WordPress »

Permisos VPS, no actualiza plugins

Estas en el tema de Permisos VPS, no actualiza plugins en el foro de WordPress en Foros del Web. Tengo un WordPress en VPS y no logro que se actualicen los plugins, me temo que es por un problema de permisos. Todo lo demás ...
  #1 (permalink)  
Antiguo 07/07/2018, 14:07
 
Fecha de Ingreso: junio-2011
Mensajes: 13
Antigüedad: 7 años, 6 meses
Puntos: 1
Permisos VPS, no actualiza plugins

Tengo un WordPress en VPS y no logro que se actualicen los plugins, me temo que es por un problema de permisos. Todo lo demás funciona bien.

El VPS es Linux de OVH, con Webmin, todo funciona bien menos lo de actualizar plugins. Toda la carpeta donde tengo el WordPress tiene usuario y grupo: "userwp:grupowp". He probado de meter el userwp en todos los grupos y también en agregar todos los usuarios posibles al grupo groupwp, no hay manera.

Los permisos de las carpetas son los correctos, debe ser un error a nivel de permisos más de raíz de servidor.

A ver si me podéis guiar un poco para resolver este problema. Gracias.

Última edición por ienlaces; 07/07/2018 a las 14:27
  #2 (permalink)  
Antiguo 07/07/2018, 14:32
 
Fecha de Ingreso: junio-2011
Mensajes: 13
Antigüedad: 7 años, 6 meses
Puntos: 1
Respuesta: Permisos VPS, no actualiza plugins

Lo he logrado añadiendo el usuario Apache al directorio de la web:

chown -R apache:userwp home/directoriowp
  #3 (permalink)  
Antiguo 07/12/2018, 16:30
Avatar de metacortex
Viejo demente
 
Fecha de Ingreso: junio-2004
Ubicación: Caracas - Venezuela
Mensajes: 9.024
Antigüedad: 14 años, 6 meses
Puntos: 832
Respuesta: Permisos VPS, no actualiza plugins

Cita:
Iniciado por ienlaces Ver Mensaje
Los permisos de las carpetas son los correctos, debe ser un error a nivel de permisos más de raíz de servidor.
Es posible. En un servidor compartido el chmod de archivos y directorios es 644 y 755 respectivamente. Pero hay ciertas configuraciones de servidor que exigen 664 y 775, que aún ofrecen seguridad. Intenta cambiarlos a estos últimos a ver cómo resulta. (Y por favor, no cambies nada a 777, vale?)



La zona horaria es GMT -6. Ahora son las 20:25.