Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » WordPress »

Problema permalinks

Estas en el tema de Problema permalinks en el foro de WordPress en Foros del Web. Buenas tardes, Estoy teniendo problemas a la hora de establecer la estructura de los enlaces. Concretamente quiero ajustar los enlaces con la siguiente estructura: /%year%/%monthnum%/%postname%/ ...
  #1 (permalink)  
Antiguo 06/04/2011, 05:28
 
Fecha de Ingreso: noviembre-2007
Ubicación: San Juan de Alicante
Mensajes: 78
Antigüedad: 11 años, 11 meses
Puntos: 7
Problema permalinks

Buenas tardes,
Estoy teniendo problemas a la hora de establecer la estructura de los enlaces. Concretamente quiero ajustar los enlaces con la siguiente estructura:
/%year%/%monthnum%/%postname%/

TRas cambiar este ajuste cambiar el .htacces con este código:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

La web me devuelve un erro 404 en cada una de las secciones de la web.

¿Alguna sugerencia?

Gracias
  #2 (permalink)  
Antiguo 06/04/2011, 07:06
armandas
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema permalinks

Hola, una cosilla, lo tienes instalado en servidor local o en un hosting de pago ?
  #3 (permalink)  
Antiguo 06/04/2011, 07:48
 
Fecha de Ingreso: noviembre-2007
Ubicación: San Juan de Alicante
Mensajes: 78
Antigüedad: 11 años, 11 meses
Puntos: 7
Respuesta: Problema permalinks

Hola armandas, la web esta alojada en un hosting de pago
  #4 (permalink)  
Antiguo 07/04/2011, 01:40
armandas
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: Problema permalinks

Bien, intenta comunicarte con el servicio técnico y decirles que activen el módulo "rewrite_module" asi podrás hacer los cambios en permalinks y que no te de problemas. No estoy 100% seguro de que este sea tu problema, pero a más de uno le ha servido.

Un saludo!

Ya nos cuentas como te fue..
  #5 (permalink)  
Antiguo 07/04/2011, 03:50
 
Fecha de Ingreso: noviembre-2007
Ubicación: San Juan de Alicante
Mensajes: 78
Antigüedad: 11 años, 11 meses
Puntos: 7
Respuesta: Problema permalinks

gracias armandas, voy a ver que dicen del hosting y te cuento qué tal ha ido
  #6 (permalink)  
Antiguo 11/04/2011, 08:23
 
Fecha de Ingreso: noviembre-2007
Ubicación: San Juan de Alicante
Mensajes: 78
Antigüedad: 11 años, 11 meses
Puntos: 7
Respuesta: Problema permalinks

Buenas tardes,
El Hosting me contestó que estaba activado el módulo "rewrite_module", y me dijo que añadiera en el . htacces el siguiente código:
Código:
[email protected] httpdocs# ls -lha
total 268K
drwxr-x---  5 pasape7127 psaserv 4,0K abr  9 03:30 .
drwxr-xr-x 14 root       root    4,0K mar  8 09:55 ..
-rw-r--r--  1 pasape7127 psacln    53 abr  7 13:32 googled3a0fb9056e052c0.html
-rw-rw-rw-  1 pasape7127 psacln   199 abr  6 13:21 .htacces
-rw-r--r--  1 pasape7127 psacln   397 mar 30 18:49 index.php
-rw-r--r--  1 pasape7127 psacln   18K mar 30 18:49 licencia.txt
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>
Haciendo todo esto, el WP me ha creado los enlaces según la estructura que he definido, pero no me encuentra los archivos, el navegador me devuelve el siguiente error:
"The requested document was not found on this server."

Alguna sugerencia??
  #7 (permalink)  
Antiguo 12/04/2011, 11:37
 
Fecha de Ingreso: noviembre-2007
Ubicación: San Juan de Alicante
Mensajes: 78
Antigüedad: 11 años, 11 meses
Puntos: 7
Respuesta: Problema permalinks

problema solucionado!

gracias
  #8 (permalink)  
Antiguo 25/04/2011, 12:08
Avatar de 365dias  
Fecha de Ingreso: abril-2011
Mensajes: 1
Antigüedad: 8 años, 5 meses
Puntos: 0
Respuesta: Problema permalinks

¿¡Pero porqué no has puesto la solución?! digo, que bueno que arreglaste el problema, pero ¡¿cómo?!... la idea de un foro también es que en visitas posteriores quienes tenemos el mismo problema encontremos soluciones ¡¡COMPARTE!!
  #9 (permalink)  
Antiguo 25/04/2011, 13:26
 
Fecha de Ingreso: noviembre-2007
Ubicación: San Juan de Alicante
Mensajes: 78
Antigüedad: 11 años, 11 meses
Puntos: 7
Respuesta: Problema permalinks

Tienes razón 365días, lo siento.

Finalmente solucioné el problema poniendo en contacto con mi empresa de hosting, otra vez, para que me configuraran bien el servidor, ya que el problema radicaba en el servidor.

Tras los cambios que me realizaron en el servidor, pude establecer los permalinks con la siguiente estructura: /%postname%/

Así que si tienes el mismo problema que tenía yo, ponte en contacto con tu hosting y hazles ver que el problema está en el servidor.

Suerte
un saludo

Etiquetas: permalinks, seo
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 02:24.