Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Joomla »

ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

Estas en el tema de ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17! en el foro de Joomla en Foros del Web. Hemos sabido que Joomla ha liberado hace unas semanas atrás la actualización de Joomla 1.5.15 a 1.5.16 , pero dicha actualización creaba conflictos en el ...
  #1 (permalink)  
Antiguo 13/05/2010, 11:18
Avatar de Larenz
Colaborador
 
Fecha de Ingreso: enero-2007
Ubicación: Nicaragua
Mensajes: 1.398
Antigüedad: 16 años, 1 mes
Puntos: 55
Exclamación ¡Fallos en Joomla 1.5.16 y 1.5.17! NUEVO JOOMLA 1.5.18

Hemos sabido que Joomla ha liberado hace unas semanas atrás la actualización de Joomla 1.5.15 a 1.5.16, pero dicha actualización creaba conflictos en el servidor en donde se instalaba. Específicamente con la versión de PHP. Para solucionar esto lanzaron rápidamente un nuevo parche de actualización a la versión 1.5.17 la cual aún continúa teniendo problemas.

El co-fundador y ex-miembro del core de Joomla, Johan Janssens ha recomendado no actualizar a Joomla 1.5.17 y permanecer aún en su versión estable 1.5.15 ya que las últimas dos versiones de Joomla presentan desestabilización automática de plugins. Causando que Joomla trabaje de forma inapropiado y llevando incluso a la caída del sitio.

En las versiones de Joomla 1.5.16 y 1.5.17 se incluyó la desestabilización automática de plugins, la cual tiene como función deshabilitar cualquier plugin en Joomla que generase error durante su inicialización.

La nueva característica de estas dos últimas versiones asume que cuando un plugin lanza un error se debe a que "existe" un archivo faltante, sin embargo, ese error puede ser meramente condicional y Joomla lo puede ejecutar bajo ciertas circunstancias. Dependiendo de cómo el plugin se ejecute, así mismo trabajarían las condiciones. En vez de tirar un error el plugin es deshabilitado y se previene su ejecución bajo condiciones normales. Esto puede provocar experiencias y comportamientos extraños en el visitante o que encuentre el sitio caído.

Johan Janssens ha enviado el reporte al departamente respectivo de Joomla para que corrigan ese "bug" en una nueva versión de Joomla. Mientras tanto sigue recomendando la no actualización a Joomla 1.5.16/1.5.17

Si estás usando Joomla a la última versión actualizada y estás experimentando inestabilidades en tu sitio puedes deshabilitar la nueva función incorporada a Joomla editando el archivo helper.php el cual lo encuentras en el folder libraries/joomla/plugin borrando las líneas 122 a 136:

Código PHP:
if(!$shutdown_handler_installed)  
   {  
    
// only register the shutdown function 
    //if we are capable of checking the errors (reqs PHP 5.2+)
    
if (version_compare("5.2"phpversion(), "<="))  
    {  
     
// you can only register a static method if it is declared static  
     // we can't declare static b/c it breaks on PHP4  
     // therefore we instantiate the helper for this one purpose  
     
$pluginHelper = new JPluginHelper;  
     
register_shutdown_function(array($pluginHelper'shutdown'));  
    }  
    
// we may not have installed the handler, but setting this to true  
    // will prevent us from continually running the version compare  
    
$shutdown_handler_installed true;  
   } 
Esto no hará más que deshabilitar la función que deshabilita los plugins que se ejecutan con error causando conflictos con el sitio.

Saludos y estamos pendientes de nuevas noticias.
__________________
¡No lo sé todo! Pero comencé como tú, ¡sin saber nada!
Encuéntrame en Facebook: Perfil + Página

Última edición por Larenz; 19/05/2010 a las 11:54
  #2 (permalink)  
Antiguo 15/05/2010, 17:08
Avatar de rcarcamonster
Moderador
 
Fecha de Ingreso: enero-2008
Ubicación: Chile
Mensajes: 1.940
Antigüedad: 15 años
Puntos: 108
De acuerdo Respuesta: ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

Muchas gracias por la información Larenz. Estaré monitoreando el comportamiento de mi sitios Joomla.

Saludos!
__________________
Tucango - Desarrollo web
  #3 (permalink)  
Antiguo 17/05/2010, 08:42
Avatar de Jotaze  
Fecha de Ingreso: mayo-2010
Mensajes: 15
Antigüedad: 12 años, 9 meses
Puntos: 2
Respuesta: ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

Gracias Larenz

Estaremos pendientes para comunicar por esta vía cuando se haya corregido esto en las versiones oficiales de Joomla,

Atentamente,


Jotaze
  #4 (permalink)  
Antiguo 19/05/2010, 11:57
Avatar de Larenz
Colaborador
 
Fecha de Ingreso: enero-2007
Ubicación: Nicaragua
Mensajes: 1.398
Antigüedad: 16 años, 1 mes
Puntos: 55
Respuesta: ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

Solamente paso para comunicarles que posiblemente en esta semana o la siguiente semana estará saliendo la versión de Joomla 1.5.18 con varias correcciones para que estén pendientes de este nuevo lanzamiento del equipo Joomla.
__________________
¡No lo sé todo! Pero comencé como tú, ¡sin saber nada!
Encuéntrame en Facebook: Perfil + Página
  #5 (permalink)  
Antiguo 19/05/2010, 12:53
Avatar de CircuitoX  
Fecha de Ingreso: julio-2008
Mensajes: 756
Antigüedad: 14 años, 6 meses
Puntos: 21
Respuesta: ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

sabe alguien para cuando estara la version 1.6 estable..

Saludos y mas saludos
__________________
Diseño Robotico en Arequipa / Desarrollo web / Sitios / Paginas / 99 css3
  #6 (permalink)  
Antiguo 20/05/2010, 03:05
Avatar de redlo41  
Fecha de Ingreso: agosto-2008
Ubicación: Santomera - Murcia
Mensajes: 241
Antigüedad: 14 años, 5 meses
Puntos: 4
Respuesta: ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

Gracias por el apunte. Son bastantes las personas con este tipo de problema. Gracias tio.
__________________
www.SolojooMLa.com
La vida es demasiado corta, como para tomarsela en serio
  #7 (permalink)  
Antiguo 29/05/2010, 09:36
Avatar de rcarcamonster
Moderador
 
Fecha de Ingreso: enero-2008
Ubicación: Chile
Mensajes: 1.940
Antigüedad: 15 años
Puntos: 108
Mensaje Respuesta: ERROR EN JOOMLA: ¡Fallos en Joomla 1.5.16 y 1.5.17!

Hola, les aviso que la versión 1.5.18 salió hace unas horas y fueron corregidos la totalidad de los errores de las dos versiones anteriores.

Se recomienda actualizar a la brevedad.
Saludos

http://www.joomla.org/download.html
__________________
Tucango - Desarrollo web

Etiquetas: 1.5.16, 1.5.17, actualizaciones
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 19:49.