Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Joomla »

el feed rss de un componente de joomla no se actualiza

Estas en el tema de el feed rss de un componente de joomla no se actualiza en el foro de Joomla en Foros del Web. buenas tardes, soy nuevo en el foro. tengo un feed rss de un componente para inmobiliaria que lo estoy usando en mi sistema joomla, este ...
  #1 (permalink)  
Antiguo 19/04/2011, 13:41
jyegestiones
Invitado
 
Mensajes: n/a
Puntos:
Pregunta el feed rss de un componente de joomla no se actualiza

buenas tardes, soy nuevo en el foro.
tengo un feed rss de un componente para inmobiliaria que lo estoy usando en mi sistema joomla, este feed existe porque cuando accedo a el como si fuera una web en cualquier navegador se visualiza bien, el caso es que este feed me tarda un poco en cargar y servicios como feedburner y twitterfeed no me lo quieren recibir, dan error.
¿Porque es que si el feed existe estos servicios no lo quieren recibir?

otra cosa, quiero enviarles el url del feed rss, pero no se si esta permitido.

Otra pregunta: ¿hay una manera de hacer un scripts desde cero, subirlo al servidor donde esta la web, conectarlo con la base de datos del sitio web joomla y que este scripts funcione como un nuevo feed rss?
ojala se entienda lo que quiero.

Gracias a todos lo que responderán.

Última edición por jyegestiones; 19/04/2011 a las 13:46 Razón: añadir una pregunta
  #2 (permalink)  
Antiguo 20/04/2011, 11:09
jyegestiones
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: el feed rss de un componente de joomla no se actualiza

No se realmente que estará pasando con este feed, la web esta en un servidor dedicado o vps, y el soporte tecnico del hosting me dice que al momento de cargar este feed jala bastante memoria de la ram.
Se me he puesto algo en mente, se me ha puesto de crear un feed rss dinamico manualmente, programarlo y subirlo al hosting para que se actualice cada vez que se agregan o modifiquen inmuebles de las tablas del componente IProperty.
Quería saber su opinión, si esto puede resultar.
Estuve haciendo una prueba siguiendo un videotutorial que encontré. y todo iba bien, pero no se porque no se listan los inmuebles en el feed y me sale un error.
Por si acaso les pongo los codigos:

archivo: rss.php
Código:
<?php 
header("Content-type: application/rss+xml"); 
echo "<?xml version='1.0' encoding='iso-8859-1'?>";
?>
<rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">
  <channel> 
    <title><![CDATA[Rss de Kolonos Group SA]]></title> 
    <link><![CDATA[http://kolonosgroup.com]]></link> 
    <description><![CDATA[Nuevos Inmuebles Publicados]]></description>
    <language>es-es</language> 
    <copyright><![CDATA[Kolonos Group SA - Argentina 2011]]></copyright>
    <atom:link href="http://kolonosgroup.com/rss.php" rel="self" type="application/rss+xml" />
    <ttl>15</ttl> 

   <image>
      <url>url de una imagen</url>

      <title>Nuevos Inmuebles Publicados</title>
      <link>http://kolonosgroup.com</link>
   </image>
<?php
require_once("class/class.php");
$tra=new rss();
$datos=$tra->get_jos_iproperty();
for ($i=0;$i<sizeof($datos);$i++)
{
?>
<item>
   <title>
   <![CDATA[Titulo del inmueble publicado en IProperty]]>
   </title>
   <link>
   <![CDATA[Url del inmueble publicado en IProperty]]>
   </link>
   <description>
   <![CDATA[<div align='justify'>Descriocion del Inmueble Publicado en IProperty</div>]]>
   </description>
   <guid isPermaLink="true">
   <![CDATA[permalink del inmueble publicado en IProperty]]>
   </guid>
   <author>
   <![CDATA[Agente que publico el inmueble en Iproerty]]>
   </author>
   <pubDate>
   <![CDATA[fecha de actualizacion del inmueble publicado en Iproperty]]>
   </pubDate>
</item>
<?php
}
?>
</channel>
</rss>
y este otro archivo: class.php
Código:
<?php
class conectar
{

   public static function con()
   {
      $con=mysql_connect("host de la bd","usuario de la bd","contraseña de la bd");
      mysql_query("SET NAMES 'utf8'");
      mysql_select_db("nombre de la bd");
      return $con;
   }
}
class rss
{
   private $jos_iproperty;
   
   public function __construct()
   {
      $this->jos_iproperty=array();
   }
   public function get_jos_iproperty()
   {
      $sql="selec * from order by modified desc";
      $res=mysql_query($sql,conectar::con());
      while ($reg=mysql_fetch_assoc($res))
      {
         $this->jos_iproperty[]=$reg;
      }
         return $this->jos_iproperty;
   }
}
?>
y el unico navegador que me dice donde esta el error es el google chrome y me da este error:

Código:
<?xml version='1.0' encoding='iso-8859-1'?><rss version="2.0" xmlns:atom="http://www.w3.org/2005/Atom">
  <channel> 
    <title><![CDATA[Rss de Kolonos Group SA]]></title> 
    <link><![CDATA[http://kolonosgroup.com]]></link> 
    <description><![CDATA[Nuevos Inmuebles Publicados]]></description>
    <language>es-es</language> 
    <copyright><![CDATA[Kolonos Group SA - Argentina 2011]]></copyright>
    <atom:link href="http://kolonosgroup.com/rss.php" rel="self" type="application/rss+xml" />
    <ttl>15</ttl> 

	<image>
		<url>ruta de la imagen</url>

		<title>Nuevos Inmuebles Publicados</title>
		<link>http://kolonosgroup.com</link>
	</image>
<br />
<b>Warning</b>:  mysql_fetch_assoc(): supplied argument is not a valid MySQL result resource in <b>/homeabc/abcxyz/public_html/class/class.php</b> on line <b>25</b><br />
</channel>
</rss>
Alguna idea, sera factible corregir esto y hacer que funcione asi?
  #3 (permalink)  
Antiguo 22/04/2011, 10:43
jyegestiones
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: el feed rss de un componente de joomla no se actualiza

Pues vera, mi intensión es crear manualmente un feed rss de una de las 126 tablas que hay en mi base de datos mysql de mi instalacion de joomla, y buscando informacion encontre este generador que se llama [URL="http://www.endsdesign.com/scripts/"]rss generator v1[/URL] (esta al final dela pagina web) que veo que hace lo que quiero; descague su demo y lo instale muy bien en mi servidor de acuerdo con las indicaciones, y cuando quise probar y generar el feed eligiendo la tabla correspondiente me sale un error.
No se si el error sera porque en el campo de url adrede le puse cualquier cosa, es que no se que poner ahi para que se genere el enlace correspondiente.
Si alguien a usado este rss generator quería saber si pueden contarme su experiencia.

Etiquetas: componente, feed, rss
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:55.