Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Joomla »

Modulos de menu ??

Estas en el tema de Modulos de menu ?? en el foro de Joomla en Foros del Web. Hola a todos Hace unos dias instale el joomla 1.5.3 si no me equivoco y estube descargando varias plantillas para probar como se veia y ...
  #1 (permalink)  
Antiguo 27/04/2008, 14:55
 
Fecha de Ingreso: julio-2005
Mensajes: 7
Antigüedad: 15 años
Puntos: 0
Modulos de menu ??

Hola a todos
Hace unos dias instale el joomla 1.5.3 si no me equivoco y estube descargando varias plantillas para probar como se veia y me doy con la sorpresa que algunas no las lee no se por que :S
bueno y el problema principal que mas me molesta es como aplicar el ja transmenu ?
queria hacer mi propio template y usar este modulo de menu pero no me funciona
cuando lo activo en la plantilla este me da errores
como este

Código HTML:
Warning: include_once(C:\AppServ\www\Joomla/modules/ja_transmenu/jamenu.php) [function.include-once]: failed to open stream: No such file or directory in C:\AppServ\www\Joomla\modules\mod_ja_transmenu\mod_ja_transmenu.php on line 15

Warning: include_once() [function.include]: Failed opening 'C:\AppServ\www\Joomla/modules/ja_transmenu/jamenu.php' for inclusion (include_path='.;C:\php5\pear') in C:\AppServ\www\Joomla\modules\mod_ja_transmenu\mod_ja_transmenu.php on line 15

Fatal error: Class 'JAMenu' not found in C:\AppServ\www\Joomla\modules\mod_ja_transmenu\mod_ja_transmenu.php on line 17
saludos y gracias
  #2 (permalink)  
Antiguo 09/04/2010, 17:50
Avatar de DHH
DHH
 
Fecha de Ingreso: junio-2009
Mensajes: 8
Antigüedad: 11 años
Puntos: 0
Busqueda Respuesta: Modulos de menu ??

Hola, ese problema es facil de solucionar.

Ya que el transmenu que hoy en dia conocemos esta basado para para laversion de joomla 1.0.... y las rutas de las carpetas en la parte de modulos varian.

busca tu archivo mod_ja_transmenu.php

y en la linea donde se encuentra este codigo:

Código PHP:
$params->set'module_name''JA Trans Menu' );
$params->set'module''ja_transmenu' );
$params->set'absPath'$mosConfig_absolute_path '/modules/' $params->get'module' ) ); 
reemplazalo por:

Código PHP:

$params
->set'module_name''JA Trans Menu' );
$params->set'module''mod_ja_transmenu/ja_transmenu' );
$params->set'absPath'$mosConfig_absolute_path '/modules/' $params->get'module' ) ); 
eso es todo, espero que te sea de ayuda!!!

DHH - D2H
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:36.