Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Joomla »

Quitar cuadro azul de link en imagen de plantilla Beez_20.

Estas en el tema de Quitar cuadro azul de link en imagen de plantilla Beez_20. en el foro de Joomla en Foros del Web. Buenos días, Problema sencillo pero que me trae de cabeza. En la plantilla Beez_20 al pasar el cursor sobre las imágenes que funcionan como link ...
  #1 (permalink)  
Antiguo 21/09/2012, 06:22
 
Fecha de Ingreso: agosto-2009
Mensajes: 91
Antigüedad: 13 años, 1 mes
Puntos: 2
Quitar cuadro azul de link en imagen de plantilla Beez_20.

Buenos días,

Problema sencillo pero que me trae de cabeza. En la plantilla Beez_20 al pasar el cursor sobre las imágenes que funcionan como link me aparece un cuadro azul que no se quitar. ¿Hay alguna manera de hacerlo?

He probado editando personal.css y añadiendo:

a: hover, a:active, a:focus {
background-color: #FFF;
color: #FFF;
}

Lo mismo pero con "none" en lugar del color y no hay manera.

Y ya puesto pregunto.. ¿Alguna plantilla gratuita mejor que Beez_20 para Joomla 2.5 y VirtueMart2?

Muchísimas gracias!
  #2 (permalink)  
Antiguo 26/09/2012, 09:21
Avatar de chabri  
Fecha de Ingreso: septiembre-2009
Ubicación: Torremolinos
Mensajes: 227
Antigüedad: 13 años
Puntos: 17
Respuesta: Quitar cuadro azul de link en imagen de plantilla Beez_20.

En el css de la plantilla por algún lado tiene que poner que los "a" tengan fondo azul.

Puedes probar esto, pero se aplicaría a todas las imágenes que funcionan como links:

a:hover {
background-color: none !important;
}

o

a:hover {
background-color: white !important;
}

Saludos.
  #3 (permalink)  
Antiguo 27/09/2012, 06:59
 
Fecha de Ingreso: agosto-2009
Mensajes: 91
Antigüedad: 13 años, 1 mes
Puntos: 2
Respuesta: Quitar cuadro azul de link en imagen de plantilla Beez_20.

Buenos días y gracias por la respuesta Chabri,

He probado las líneas que me has propuesto y no consigo hacer desaparecer el dichoso cuadro azul. He probado añadiéndolas a templates/beez_20/css/personal.css, también a templates/beez_20/css/general.css y a templates/beez_20/css/template.css sin obtener ningún cambio.

A la desesperada he editado y añadido las líneas que propones en components/com_virtuemart/assets/css/vmsite-ltr.css también sin ningún resultado.

Dejo el link a la web de prueba por si os puede facilitar la ayuda: http://www.projectux.cs.uab.es/~1158125/PFC/

Muchas gracias.
  #4 (permalink)  
Antiguo 27/09/2012, 07:29
Avatar de pitufoweb  
Fecha de Ingreso: enero-2008
Ubicación: Un Mundo Raro
Mensajes: 1.148
Antigüedad: 14 años, 8 meses
Puntos: 181
Respuesta: Quitar cuadro azul de link en imagen de plantilla Beez_20.

prueba con este codigo

html #main a:hover, html #main a:active, html #main a:focus {
background: transparent;
color: #FFFFFF;
}



Saludos
__________________
------------- " La felicidad no llega de afuera, nace desde dentro. " -------------

Última edición por pitufoweb; 27/09/2012 a las 07:40
  #5 (permalink)  
Antiguo 27/09/2012, 13:36
Avatar de chabri  
Fecha de Ingreso: septiembre-2009
Ubicación: Torremolinos
Mensajes: 227
Antigüedad: 13 años
Puntos: 17
Respuesta: Quitar cuadro azul de link en imagen de plantilla Beez_20.

Buenas! he encontrado el css, es el personal.css y en la linea 43 aprox. sale el a:hover

a:hover,
a:active,
a:focus
{
background:#095197;
color:#FFF;
}

Quitalo o bien cambia de color. Un saludo.
  #6 (permalink)  
Antiguo 28/09/2012, 06:04
 
Fecha de Ingreso: agosto-2009
Mensajes: 91
Antigüedad: 13 años, 1 mes
Puntos: 2
Respuesta: Quitar cuadro azul de link en imagen de plantilla Beez_20.

Mil gracias chicos!! Parece que algo ha cambiado. He probado a eliminar las líneas que comenta chabri y aunque sea lógico lo que propone, continuaba igual mostrando el cuadro azul.
Con el código de pitufoweb han desaparecido los cuadros azules en las imágenes pero además de las imágenes también me desaparecen los links al pasar el cursor por encima.
Voy a probar a ver si puedo decirle al código que tan solo se aplique a las "img".

Se aceptan sugerencias. Un saludo :)

EDITO: SOLUCIONADO!! Utilizando el código de pitufoweb he puesto "color: #000;" para que los links no sean blancos al pasar el cursor por encima y den la sensación de desaparecer. Ahora ya aparecen los links en negro y en cuanto a las fotos ya no lucen el color azul de fondo.

Infitintas gracias a todos!!

Última edición por jurassicboy; 28/09/2012 a las 08:23

Etiquetas: azul, cuadro, link, plantilla
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:55.