Foros del Web » Programando para Internet » Python »

[SOLUCIONADO] heroku django no muestra imgenes

Estas en el tema de heroku django no muestra imgenes en el foro de Python en Foros del Web. hola heroku no me esta mostrando las imagenes en django solo me carga el css pero no las imagenes que tengo que hacer...
  #1 (permalink)  
Antiguo 02/08/2014, 17:57
 
Fecha de Ingreso: diciembre-2011
Mensajes: 408
Antigüedad: 10 años, 6 meses
Puntos: 18
heroku django no muestra imgenes

hola heroku no me esta mostrando las imagenes en django solo me carga el css pero no las imagenes que tengo que hacer
  #2 (permalink)  
Antiguo 02/08/2014, 19:49
Avatar de razpeitia
Moderador
 
Fecha de Ingreso: marzo-2005
Ubicación: Monterrey, México
Mensajes: 7.321
Antigüedad: 17 años, 3 meses
Puntos: 1360
Respuesta: heroku django no muestra imgenes

Mira, a estas alturas yo esperaría.

Hola a todos, no puedo servir imágenes, el /static/ si funciona pero el /media/ no. Este es mi settings.py que uso para producción (posiblemente sin contraseñas hardcodeadas).

Mínimo esperaría eso de ti. Lo que tu esperarías de mi:

Y entonces te digo que en heroku, no puedes almacenar archivos estáticos que sean /media/ porque tu proyecto de heroku *argumentos técnicos*.

Así que te recomendaría usar *tal librería* que te sirve para solucionar al menos lo de los archivos estáticos /static/ en cuanto a tus archivos media vas a tener que *otra solución*.

Y bueno así se siente cuando no te dan suficiente información del problema, recuerda somos humanos y lo que sea que tengas en tu pantalla o en tu proyecto no podemos verlo. Y mucho menos podemos leerte la mente como para saber en que te esta fallando.
  #3 (permalink)  
Antiguo 26/10/2014, 22:29
 
Fecha de Ingreso: octubre-2014
Mensajes: 1
Antigüedad: 7 años, 8 meses
Puntos: 0
Respuesta: heroku django no muestra imgenes

bueno, te entiendo ya que tengo el mismo problema, el cual boy a detallar a continuación:

como dices, los archivos que tengo en la carpeta static si me cargan en cambio los de media que en este caso tengo mis imágenes no, pero eso sucede en mi caso cuando pongo el DEBUG = False


en setting.py tengo:

Código Python:
Ver original
  1. DEBUG = False
  2. TEMPLATE_DEBUG = False
  3. ALLOWED_HOSTS = ['myapp.herokuapp.com']
  4.  
  5. MEDIA_URL = '/media/'
  6. MEDIA_ROOT = os.path.join(BASE_DIR, 'webapp/media')
  7.  
  8. STATIC_URL = '/static/'
  9. import os
  10. STATIC_ROOT = os.sep.join(os.path.abspath(__file__).split(os.sep)[:-2]+['static'])


urls.py, aparte de la configuración básica, tengo:

Código Python:
Ver original
  1. from django.conf import settings
  2. if settings.DEBUG:
  3.     # static files (images, css, javascript, etc.)
  4.     urlpatterns += patterns('',
  5.         (r'^media/(?P<path>.*)$', 'django.views.static.serve', {
  6.         'document_root': settings.MEDIA_ROOT}))

OjO: no puedo ver las imágenes que tengo en la carpeta media solo cuando pongo el DEBUG = False

Etiquetas: django, heroku, muestra
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:28.