Foros del Web » Creando para Internet » Sistemas de gestión de contenidos » Drupal »

usuarios no ven slideshow

Estas en el tema de usuarios no ven slideshow en el foro de Drupal en Foros del Web. Hola, he instalado un slideshow en mi web con el viewslideshow, en drupal 7, pero solo los administradores pueden verlo, los usuarios registrados no lo ...
  #1 (permalink)  
Antiguo 13/08/2011, 08:28
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
usuarios no ven slideshow

Hola, he instalado un slideshow en mi web con el viewslideshow, en drupal 7, pero solo los administradores pueden verlo, los usuarios registrados no lo ven.Aparentemente tengo todos los permisos necesarios activados, pero no logro hacerlo visible para todos.Alguna idea??Gracias.
  #2 (permalink)  
Antiguo 13/08/2011, 17:55
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

Fijate si el contenido del slideshow esta publicado y/o los usuarios tienen acceso al mismo.
  #3 (permalink)  
Antiguo 13/08/2011, 19:39
raulfw
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: usuarios no ven slideshow

A mi me paso algo parecido con un modulo hace un par de dias, y era por culpa de los permisos.

Lo que dice Mario tiene bastante sentido. Revisa los contenidos que muestra el slideshow
  #4 (permalink)  
Antiguo 13/08/2011, 21:33
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

Hola amigos, pues la verdad es que ya lo he revisado todo y nada,sigue igual.Ya no sé que hacer ni donde mirar, pero seguiré investigando.Muchas gracias por sus respuestas.
  #5 (permalink)  
Antiguo 18/08/2011, 08:47
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

¿puede que sea un problema de acceso al contenido?Porque he creado una pagina basica pero tampoco tienen acceso los usuarios registrados ni anonimos.

El caso es que tengo los permisos de "ver el contenido" activos.

Algun conflicto con el content access??
  #6 (permalink)  
Antiguo 18/08/2011, 14:10
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

Lo que creas esta publicado?
  #7 (permalink)  
Antiguo 18/08/2011, 16:58
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

Hola Mario, si que está publicado.Tengo tres imagenes creadas para el slider, y las tres están totalmente accesibles con el content access, pero no se ven.Además me he quedado de piedra cuando al crear una pagina tampoco se ve.
Pus no sé.
  #8 (permalink)  
Antiguo 19/08/2011, 02:46
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

Pero no hablo del content access (eso no es un permiso?) ... hablo de si, al crear el nodo, vos lo pones como "publicado" (o published) en el formulario.
  #9 (permalink)  
Antiguo 19/08/2011, 05:52
raulfw
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: usuarios no ven slideshow

Yo creo que no lo tiene publicado.

Ves a:

Administracion de contenido > Contenido

Y asegurate de que ese contenido esta 'PUBLICADO'
  #10 (permalink)  
Antiguo 19/08/2011, 06:55
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

hola raulfw, si que lo tengo publicado, ESTADO: Publicado.Estoy mas que seguro,jeje.
  #11 (permalink)  
Antiguo 19/08/2011, 08:22
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

No tenes nada agregado al fichero node-tpl.php?
Si no, en opciones de contenido, reconstrui los permisos y proba a ver si funciona
  #12 (permalink)  
Antiguo 22/08/2011, 11:37
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

Hola Mario, no tengo nada agregado a ese fichero.¿como se reconstruyen permisos en drupal 7?No veo la opción.Y otra cosa, cuando reconstruimos permisos que quiere decir exactamente?, que tengo que volver a dar permisos uno por uno a todo el contenido o como?

Gracias por el interes que muestran en ayudarme, un saludo.
  #13 (permalink)  
Antiguo 22/08/2011, 14:52
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

Dejame ver la web, enviame otro privado y te ayudo cuando pueda ... pero podes probar reinstalar drupal.

En drupal 6 se reconstruyen los permisos yendo a admin / content / post settings ... en drupal 7 no creo q haya cambiado mucho.

Saludos.
  #14 (permalink)  
Antiguo 26/08/2011, 05:49
(Desactivado)
 
Fecha de Ingreso: septiembre-2008
Mensajes: 270
Antigüedad: 9 años, 10 meses
Puntos: 22
Respuesta: usuarios no ven slideshow

Cita:
Iniciado por man5on Ver Mensaje
Hola Mario, no tengo nada agregado a ese fichero.¿como se reconstruyen permisos en drupal 7?No veo la opción.Y otra cosa, cuando reconstruimos permisos que quiere decir exactamente?, que tengo que volver a dar permisos uno por uno a todo el contenido o como?

Gracias por el interes que muestran en ayudarme, un saludo.
Hola Manson, a mi paso algo parecido hace unos minutos, hice un slidershow y solo el administrador podia ver ese slidershow, otro usuario no lo veia, pero asi como dice Mario, el problema esta en los permisos, en mi caso, el campo que utizo para la imagenes cuando lo creo en tipos de contenidos, es llamado banner, entonces, cuando haces tu slidershow, vas permisos, y en

módulo content_permissions

marquee el checkmax al permiso

view field_banner

tanto en usuarios registrados como en anonimos. y Listo!. Mario tiene razon cuando te hablo de los permisos.
  #15 (permalink)  
Antiguo 05/09/2011, 12:17
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

Hola amigos, esto ya es imposible, no doy con la solucion, todo lo k me decis esta correcto, alguna idea más?
  #16 (permalink)  
Antiguo 05/09/2011, 15:04
raulfw
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: usuarios no ven slideshow

estas intentando mostrar algun contenido hecho con CCK dentro del slideshow?

tienen sus propios permisos...


Por ejemplo, yo tengo un jcarosel que muestra unas imagenes de 'taxonomy image'. Este ultimo tiene sus propios permisos.
Dicho de otra manera... a veces no solo hay que darle permisos al carousel o slideshow, sino tambien al contenido que hay dentro.

Última edición por raulfw; 05/09/2011 a las 15:11
  #17 (permalink)  
Antiguo 06/09/2011, 01:06
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

Pasame los accesos por privado man5on y veo q puedo hacer, si queres...
  #18 (permalink)  
Antiguo 06/09/2011, 01:31
 
Fecha de Ingreso: diciembre-2005
Ubicación: Barcelona
Mensajes: 1.428
Antigüedad: 12 años, 6 meses
Puntos: 15
Respuesta: usuarios no ven slideshow

A mi me pasó algo parecido después de instalar el modulo content access. Lo solucioné desinstalando el modulo y reconstruyendo permisos. No recuerdo donde estaba... busca algo que ponga: Rebuild Permissions.
  #19 (permalink)  
Antiguo 07/09/2011, 02:46
 
Fecha de Ingreso: agosto-2011
Mensajes: 29
Antigüedad: 6 años, 11 meses
Puntos: 0
Respuesta: usuarios no ven slideshow

Tienes los permisos de los preset de imagecache que usas activados para el resto?
  #20 (permalink)  
Antiguo 07/09/2011, 15:11
Avatar de MarioAraque
Colaborador
 
Fecha de Ingreso: octubre-2009
Ubicación: Valencia
Mensajes: 1.398
Antigüedad: 8 años, 9 meses
Puntos: 265
Respuesta: usuarios no ven slideshow

Ahi te lo deje funcionando.
El problema lo tenes en ese modulo content_access que tenes instalado, la verdad no se para que lo usas, pero lo deshabilite (no lo desinstale), y ahora ves el slider con un usuario anonimo.

Si lo habilitas y reconstruis los permisos ya te deja de funcionar, asi que te recomiendo que no lo uses .... y que busques una solucion a su funcionalidad de otro modo.

Saludos.
  #21 (permalink)  
Antiguo 07/09/2011, 16:53
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

Muchas gracias a Mario y a todos los que se han ofrecido.Tendré que buscar otra alternativa al content access, pork si bien ahora no me resuelve mucho y es el que me crea conflictos, creo que pronto necesitaré algo parecido.

Un saludo y gracias.
  #22 (permalink)  
Antiguo 07/09/2011, 18:07
raulfw
Invitado
 
Mensajes: n/a
Puntos:
Respuesta: usuarios no ven slideshow

Yo tengo instalado 'content access' y la verdad, no le encuentro la utilidad. Al final siempre acabo ajustando todo en 'permisos'...
  #23 (permalink)  
Antiguo 08/09/2011, 07:57
 
Fecha de Ingreso: noviembre-2007
Mensajes: 50
Antigüedad: 10 años, 8 meses
Puntos: 1
Respuesta: usuarios no ven slideshow

Tendré k usar algo parecido, abriré otro hilo.

Etiquetas: slideshow, usuarios, ven, views
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 14:29.