Foros del Web » Programando para Internet » PHP » Configuración PHP »

no se pudo cargar la extensión mysql

Estas en el tema de no se pudo cargar la extensión mysql en el foro de Configuración PHP en Foros del Web. Hola amigos, Tengo un problema con la instalaciónn de phpmyadmin en centOS 5.2, instale php 5.3 y mysql 5.1, hasta ahi perfecto, pero trate de ...
  #1 (permalink)  
Antiguo 19/11/2009, 20:21
Avatar de josegambo  
Fecha de Ingreso: mayo-2008
Mensajes: 5
Antigüedad: 10 años
Puntos: 1
Exclamación no se pudo cargar la extensión mysql

Hola amigos,

Tengo un problema con la instalaciónn de phpmyadmin en centOS 5.2, instale php 5.3 y mysql 5.1, hasta ahi perfecto, pero trate de instalar phpmyadmin y me sale el siguiente error.

phpMyAdmin - Error

no se pudo cargar la extensión mysql,
por favor revise su configuración de PHP. - Documentación

he buscado en foros, probe diferentes soluciones pero no he podido solucionarlo, estoy echo bolas

Mil gracias.!!
  #2 (permalink)  
Antiguo 20/11/2009, 09:52
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 12 años
Puntos: 2126
Respuesta: no se pudo cargar la extensión mysql

Revisa en este mismo foro, hay muchos temas de lo mismo, necesitas descomentar la extensión en el php.ini.

Busca la linea ;extension=php_mysql.so y quitale el ;.

Adicionalmente en algunos sistemas *nix, ya existen paquetes, como php-mysql que puedes instalar que hacen esta tarea por ti, por ejemplo en Debian:
Código:
sudo apt-get install php-mysql
Lo hace.

Saludos.
  #3 (permalink)  
Antiguo 20/11/2009, 20:30
Avatar de josegambo  
Fecha de Ingreso: mayo-2008
Mensajes: 5
Antigüedad: 10 años
Puntos: 1
Exclamación Respuesta: no se pudo cargar la extensión mysql

Hola GatorV,

mil gracias por responder,

instale php-mysql de la siguiente forma:

yum --enablerepo=remi install php-mysql

Se instalo correctamente, luego reinicie el servicio de apache y no funciona, verifique la linea de la extencion de mysql en /etc/php.ini y tampoco, no se que estoy haciendo mal.

/etc/php.ini
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;

; If you wish to have an extension loaded automatically, use the following
; syntax:
;
; extension=modulename.extension
;
; For example
;
; extension=msql.so
;
; ... or with a path:
;
extension=msql.so
;
; If you only provide the name of the extension, PHP will look for it in its
; default extension directory.

;;;;
; Note: packaged extension modules are now loaded via the .ini files
; found in the directory /etc/php.d; these are loaded by default.
;;;;

Saludos...
  #4 (permalink)  
Antiguo 23/11/2009, 09:16
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 12 años
Puntos: 2126
Respuesta: no se pudo cargar la extensión mysql

Revisa la documentación del paquete te debe de decir como es que hace ese trabajo, ya que si lo haces con el package manager no es recomendable que edites el php.ini ya que eso lo hace de forma automatica el package manager.

Saludos.
  #5 (permalink)  
Antiguo 11/10/2010, 14:36
Avatar de Nirt3  
Fecha de Ingreso: septiembre-2010
Mensajes: 21
Antigüedad: 7 años, 8 meses
Puntos: 0
Pregunta Respuesta: no se pudo cargar la extensión mysql



Hola a todos, tengo una duda referetne a ese mismo tema, Yo estoy trabajando con WindowsServer 2008 enterprise, instale el appserv-win32-2.5.10 y a la hora de correr el localhost, me marca ese mismo error, Que no puede cargar la extencion.... entonces no se si sea mi version del appserv una anterior, una reciente o que tenga q modificar para que funcione conrrectamente. Agradesco Todas las sugerencias Gracias.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta

SíEste tema le ha gustado a 1 personas




La zona horaria es GMT -6. Ahora son las 12:15.