Foros del Web » Programando para Internet » PHP » Configuración PHP »

Problema con file_get_contents()

Estas en el tema de Problema con file_get_contents() en el foro de Configuración PHP en Foros del Web. Tengo una página en pruebas en un host gratuito y el "servico técnico" me ha dicho que no puedo utilizar acceso remoto con file_get_contents(), porque ...
  #1 (permalink)  
Antiguo 29/10/2010, 13:16
 
Fecha de Ingreso: octubre-2010
Ubicación: Valladolid
Mensajes: 4
Antigüedad: 7 años, 6 meses
Puntos: 0
Problema con file_get_contents()

Tengo una página en pruebas en un host gratuito y el "servico técnico" me ha dicho que no puedo utilizar acceso remoto con file_get_contents(), porque lo tengo "capado" precisamente por la gratuidad. Hasta ahí de acuerdo. Pero es que subo la página a un host de pago y la función también me devuelve un false. ¿Puede ser porque el allow_url_fopen esté a 0 en el php.ini, como he leído por ahí, o alguien me da una pista de qué puede pasar? En local me devuelve lo que quiero perfectamente.
Gracias. Un saludo.
  #2 (permalink)  
Antiguo 30/10/2010, 05:31
 
Fecha de Ingreso: octubre-2010
Ubicación: Valladolid
Mensajes: 4
Antigüedad: 7 años, 6 meses
Puntos: 0
Respuesta: Problema con file_get_contents()

No hay manera de acceder a donde quiero ni con curl, ni con fopen.
¿Podría tener algo que ver la forma en que paso la url como parámetro? El formato de la url es este:

http://nombreservidor/carpeta/carpeta1/carpeta2/nombrefichero.php?ID=usuario&PASS=xxxxxx&QUEST=opc ionesconsulta

Lo que hace es extraer datos de una base de datos.
  #3 (permalink)  
Antiguo 04/11/2010, 04:38
 
Fecha de Ingreso: octubre-2010
Ubicación: Valladolid
Mensajes: 4
Antigüedad: 7 años, 6 meses
Puntos: 0
Respuesta: Problema con file_get_contents()

El webmaster del host dice que los puertos están abiertos. En el servidor a donde hago la petición también dicen que no hay problema, que esos accesos los hace mucha gente. Los permisos de los ficheros php están a 755 para que se puedan ejecutar. Todo funciona excepto fopen($url) y flie_get_contents($url), donde url es la url que dije antes. Ya he dicho que en local funciona. Estoy a punto de rendirme. Nadie sabe qué puede pasar?
  #4 (permalink)  
Antiguo 04/11/2010, 10:16
Avatar de maturano  
Fecha de Ingreso: enero-2010
Ubicación: /home/
Mensajes: 537
Antigüedad: 8 años, 4 meses
Puntos: 35
Respuesta: Problema con file_get_contents()

En tu primer mensaje preguntas: "¿Puede ser porque el allow_url_fopen esté a 0 en el php.ini"; sí, puede ser. ¿Pero preguntas o lo está?. No entiendo si solo apuntas a que ese puede ser el error o, en efecto, está deshabilitado en el sistema donde corres el código.

Simple: si los valores son diferentes para tu servidor local --donde funciona-- y el servidor en producción --donde falla--, ese será tu error.


Igual posteriormente dejas una URL, pero al menos yo no entiendo si esa es la URL de tu script por la que accedes mediante el navegador o es una URL que pasas como parámetro a file_get_contents(), en tal caso, ¿es texto plano?, ¿no hay código que pueda estar afectando?.

No cuentes, muestra tu código.


Por último, el resultado de file_get_contents() deberías estar asignándolo a una variable. Si haces un var_dump() a dicha variable, ¿qué obtienes?. ¿Qué te dice el log de Apache cuando ejecutas tu script?.
__________________
I ♥ The Music!
  #5 (permalink)  
Antiguo 05/11/2010, 02:43
 
Fecha de Ingreso: octubre-2010
Ubicación: Valladolid
Mensajes: 4
Antigüedad: 7 años, 6 meses
Puntos: 0
Respuesta: Problema con file_get_contents()

Tienes razón, lo expliqué bastante mal, la verdad. Ya está solucionado. Lo cambié a otro servidor y me permite "salir" a hacer el acceso remoto. Parece que es una cuestión de permisos del host donde está la web, pero no me dieron soporte. Muchas gracias, de todas formas.

Etiquetas: Ninguno
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:07.