Foros del Web » Programando para Internet » PHP » Configuración PHP »

Problema con version php 4.x.x en el servidor

Estas en el tema de Problema con version php 4.x.x en el servidor en el foro de Configuración PHP en Foros del Web. Buenas tardes, mi problema es el siguiente, he desarrollado una pagina en php 5.x.x, y el servidor al cual la tengo que subir (es un ...
  #1 (permalink)  
Antiguo 11/02/2011, 06:14
 
Fecha de Ingreso: marzo-2010
Ubicación: León
Mensajes: 23
Antigüedad: 10 años, 8 meses
Puntos: 0
Problema con version php 4.x.x en el servidor

Buenas tardes,

mi problema es el siguiente, he desarrollado una pagina en php 5.x.x, y el servidor al cual la tengo que subir (es un cliente que tiene servidor propio) esta en la version php 4.x.x.

El problema es que la pagina la subo, reconoce las paginas y las carpetas, pero no muestra nada. Salen todas las paginas en blanco.

Tambien la subi para hacer la prueba, en un servidor que soporta php 5.x.x y anda de maravilla.

Mi pregunta es la siquiente, ¿se puede hacer algo (a parte de actualizar el servidor) para que se vea la pagina?.¿Tambien necesitaria activar la opcion de PDO?

Tengo entendido que se pueden tener varias versiones de php en el servidor, si se actualizara, ¿ las web con versiones php que tiene el cliente en el servidor dejarian de funcionar?

Muchas gracias de antemano, y un saludo.
  #2 (permalink)  
Antiguo 11/02/2011, 06:19
Avatar de NUCKLEAR
Moderador radioactivo
 
Fecha de Ingreso: octubre-2005
Ubicación: Cordoba-Argentina
Mensajes: 5.688
Antigüedad: 15 años
Puntos: 890
Respuesta: Problema con version php 4.x.x en el servidor

Por que no preguntas al admninistrador del server si le pueden poner la 5.x Ya nadie usa la 4
Muchas veces lo tienen solo hay que cambiar la version desde el panel, o a travez de htaccess, o a veces de un php.ini en la raiz.
__________________
Drupal Argentina
  #3 (permalink)  
Antiguo 11/02/2011, 08:43
 
Fecha de Ingreso: marzo-2010
Ubicación: León
Mensajes: 23
Antigüedad: 10 años, 8 meses
Puntos: 0
Respuesta: Problema con version php 4.x.x en el servidor

Cita:
Iniciado por NUCKLEAR Ver Mensaje
Por que no preguntas al admninistrador del server si le pueden poner la 5.x Ya nadie usa la 4
Muchas veces lo tienen solo hay que cambiar la version desde el panel, o a travez de htaccess, o a veces de un php.ini en la raiz.
Muchas gracias por contestar,

el administrador dice que de momento no puede cambiar la version de php,

he hecho una serie de comprobaciones y encontre un problema (no se si sera el unico)

al utilizar require_once(".......loq que sea".php) me deja de mostrar las cosas

en cambio si no hago el require_once, muestra bien la pagina.

Esto a que puede ser debido? y como se solucionaria?

Porque trabajo con bastantes clases y sin el require......

Muchas gracias de nuevo.
  #4 (permalink)  
Antiguo 11/02/2011, 10:13
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 14 años, 5 meses
Puntos: 2135
Respuesta: Problema con version php 4.x.x en el servidor

Es muy complicado que hagas esa regresión sin tener que reprogramar todo, ya que si estas usando PDO, este solo funciona sobre PHP 5+, por lo cual tendrías que re-hacer yo creo todo tu sistema para trabajar con PHP4. Más si como indicas estas usando clases, recuerda que el soporte para PHP OO en PHP4 era muy simple.

Saludos.

Etiquetas: php, servidores
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 13:19.