Foros del Web » Programando para Internet » PHP » Configuración PHP »

[SOLUCIONADO] problema de php.ini para mandar mail

Estas en el tema de problema de php.ini para mandar mail en el foro de Configuración PHP en Foros del Web. Buenas! tengo algunas preguntas, espero que me puedan auxiliar, actualmente monte un servidor de correos (ARGOSOFT) hice algunos 1 par de usuarios "admin", "adrian", y ...
  #1 (permalink)  
Antiguo 05/05/2014, 15:37
 
Fecha de Ingreso: agosto-2011
Mensajes: 12
Antigüedad: 9 años, 3 meses
Puntos: 0
Pregunta problema de php.ini para mandar mail

Buenas! tengo algunas preguntas, espero que me puedan auxiliar,
actualmente monte un servidor de correos (ARGOSOFT) hice algunos 1 par de usuarios "admin", "adrian", y despues configuré el outlook de mi pc para ambos usuarios

[email protected]
[email protected]

Hice algunas pruebas de envíos con un RAD llamado scriptcase y logré mandar correos a estas cuentas.

Quizé realizar un envío en php, mediante la funcion mail

<?php

$r=mail('[email protected]','prueba','esto es una prueba de mail en php')
if($r){
echo "el correo fue enviado!";
}else{
echo "no se envió el correo";
}
?>

Desgraciadamente no estan llegando a mi bandeja de outlook, lo que investigué es la configuracion del php.ini, el cual debería tener esta configuración para mi caso...


SMTP = localhost
smtp_port = 25
sendmail_path = /usr/sbin/sendmail -t
sendmail_from = [email protected]


el problema es que no manda correos a mi cuenta y el echo me devuelve :
el correo fue enviado!

alguien sabe si me estoy saltando un paso o me falta otra cosa
(PD. tengo corriendo mi servidor de correo local)
  #2 (permalink)  
Antiguo 05/05/2014, 20:16
Avatar de Italico76  
Fecha de Ingreso: abril-2007
Mensajes: 3.303
Antigüedad: 13 años, 7 meses
Puntos: 292
Respuesta: problema de php.ini para mandar mail

Cita:
Iniciado por adrian_osravera Ver Mensaje
sendmail_path = "/usr/sbin/sendmail" -t
Asumo usas Linux en tu maquina y que el path es "correcto" pero l menos le faltan las comillas que te puse
__________________
Salu2!
  #3 (permalink)  
Antiguo 06/05/2014, 19:18
 
Fecha de Ingreso: agosto-2011
Mensajes: 12
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: problema de php.ini para mandar mail

Cita:
Iniciado por Italico76 Ver Mensaje
Asumo usas Linux en tu maquina y que el path es "correcto" pero l menos le faltan las comillas que te puse
el gran problema es que me dijeron que esa linea solucionaría el problema.. no pensé que tuviera que ver con el sistema operativo... pero pues no uso linux, tengo win 7

la linea para windows debería ser:

sendmail_path = "C:\sendmail\sendmail.exe -t" (este fichero lo tengo en C: junto con un sendamail.ini y un sendmail.exe)

aun así no manda correos a mis outlook

Última edición por adrian_osravera; 06/05/2014 a las 19:31
  #4 (permalink)  
Antiguo 06/05/2014, 21:01
 
Fecha de Ingreso: agosto-2011
Mensajes: 12
Antigüedad: 9 años, 3 meses
Puntos: 0
Respuesta: problema de php.ini para mandar mail

ya encontré la solución!!!!
es la configuración del sendmail.ini, configuré los parametros

smtp_server=localhost
smtp_port=25
auth_username=admin
auth_password=admin

y con esto ya llegan mis correos, gracias por el apoyo!!!

Etiquetas: email, mail, php, php.ini, sendmail
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 07:14.