Foros del Web » Administración de Sistemas » LAMP »

appserv 2.5.10 viene fallado el php.ini

Estas en el tema de appserv 2.5.10 viene fallado el php.ini en el foro de LAMP en Foros del Web. Hola gente: Estaba instalando el paquete de Appserv 2.5.10(que usa php ver. 5.2.6 que es la que necesito), y cuando queria ejecutar PHP desde DOS, ...
  #1 (permalink)  
Antiguo 26/06/2010, 17:45
 
Fecha de Ingreso: junio-2008
Ubicación: Capital Federal xD
Mensajes: 1.208
Antigüedad: 12 años, 3 meses
Puntos: 35
appserv 2.5.10 viene fallado el php.ini

Hola gente:
Estaba instalando el paquete de Appserv 2.5.10(que usa php ver. 5.2.6 que es la que necesito), y cuando queria ejecutar PHP desde DOS, me tiraba un alert
Código PHP:
Error al iniciar la aplicacion porque no se encontro php_mbstring.dll.
La instalacion de la aplicacion puede solucionar el problema
Y en el DOS me aparecia
Código PHP:
PHP Warning:  PHP StartupUnable to load dynamic library 'C:/AppServ\php5
\ext\php_exif.dll' 
No se puede encontrar el modulo especificado.
in Unknown on line 0 
Investigando lo arreglé modificando en el php.ini el orden en que aparecen los dll
extension=php_exif.dll
extension=php_mbstring.dll

Los invertí para que se declare primero mbstring, y PHP se ejecutó normalmente.
Es posible que se les haya escapado este detalle?!!!!!!
Me llama mucho la atención
__________________
I am Doyle please insert code.
  #2 (permalink)  
Antiguo 26/06/2010, 18:36
Avatar de abimaelrc
Colaborador
 
Fecha de Ingreso: mayo-2009
Ubicación: En el planeta de Puerto Rico
Mensajes: 14.734
Antigüedad: 11 años, 4 meses
Puntos: 1517
Respuesta: appserv 2.5.10 viene fallado el php.ini

Buen detalle, habría que ver si cuando se instala pasa lo mismo siempre, buen aporte.
__________________
Verifica antes de preguntar.
Los verdaderos amigos se hieren con la verdad, para no perderlos con la mentira. - Eugenio Maria de Hostos
  #3 (permalink)  
Antiguo 27/06/2010, 09:36
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.567
Antigüedad: 14 años, 4 meses
Puntos: 2135
Tema movido desde Configuración PHP a Paquetes tipo LAMP
  #4 (permalink)  
Antiguo 08/12/2010, 10:52
Avatar de nicosli  
Fecha de Ingreso: junio-2009
Ubicación: Cancún, Quintana Roo, Mexico
Mensajes: 72
Antigüedad: 11 años, 4 meses
Puntos: 5
Respuesta: appserv 2.5.10 viene fallado el php.ini

Hola, yo tengo el mismo problema que doylelives

Estoy modificando el php.ini pero me trae 2 archivos: php.ini-dist y php.ini-recommended. Ya modifique los 2 pero me sigue marcando el mismo problema. Otro dato que tengo es que todas las extenciones estaban comentadas ";" les quite el punto y coma

Ya reinicie el apache pero sigue con lo mismo. ¿Qué estoy haciendo mal?
  #5 (permalink)  
Antiguo 11/12/2010, 22:06
 
Fecha de Ingreso: diciembre-2010
Mensajes: 1
Antigüedad: 9 años, 10 meses
Puntos: 0
Respuesta: appserv 2.5.10 viene fallado el php.ini

No es ninguno de los dos, solo debe decir php.ini y se encuentra en la carpeta windows.

Si tienes el appserv en el menu Inicio es más fácil
Inicio/Appserv/Configuration Server/PHP Edit the php.ini Configuration File

Modificas, debe quedar en este orden:
extension=php_mbstring.dll
extension=php_exif.dll

lo grabas y listo

no te olvides de reiniciar Apache: inicio/Appserv/Control Server by Service/Apache restart

eso es todo ya debe funcionar

Etiquetas: appserv
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:13.