Foros del Web » Administración de Sistemas » LAMP »

Problema al pasar variables por URL al migrar de Xampp 1.7 a 1.8

Estas en el tema de Problema al pasar variables por URL al migrar de Xampp 1.7 a 1.8 en el foro de LAMP en Foros del Web. Buenas noches. Actualize mi vercion de Xampp a la ultima XAMPP 1.8.0, including: Apache 2.4.2 MySQL 5.5.25a PHP 5.4.4 Y ahora las paginas que pasaban ...
  #1 (permalink)  
Antiguo 26/08/2012, 20:59
 
Fecha de Ingreso: abril-2012
Mensajes: 65
Antigüedad: 10 años, 2 meses
Puntos: 0
Problema al pasar variables por URL al migrar de Xampp 1.7 a 1.8

Buenas noches.

Actualize mi vercion de Xampp a la ultima

XAMPP 1.8.0, including:

Apache 2.4.2
MySQL 5.5.25a
PHP 5.4.4

Y ahora las paginas que pasaban variables por url, no lo hacen (tambien me sucede lo mismo con easy php 12 la ultima, mientras que con las anteriores funcionan sin problema este paso de variables).

Código PHP:
href="pagina.php?usuario=<? echo $usuario?>"
y en el navegador se ve lo siguiente:

Código:
pagina.php?usuario=?usuario=<? echo $usuario; ?>
en IE9

en IE6 se ve asi

Código:
<?%20echo%20$usuario;%20?>
Debe ser un parametro de configuracion de apache o php pero no eh dado con la parte de como corregirlo.

No es un problema de programacion creo, ya que funciona correctamente con la vercion de xamp 1.7, y easyphp 4


saludos
  #2 (permalink)  
Antiguo 26/08/2012, 21:45
Avatar de mortiprogramador
Colaborador
 
Fecha de Ingreso: septiembre-2009
Ubicación: mortuoria
Mensajes: 3.805
Antigüedad: 12 años, 10 meses
Puntos: 214
Respuesta: Problema al pasar variables por URL al migrar de Xampp 1.7 a 1.8

<saludos>
Y cual es el valor de $usuario?
De donde se obtiene???

Por otra parte, si puede ser un error de programación, falta la palabra php
en el tag de inicio de código php, y se escribe verSiÓn
Revisa eso
</saludos>
__________________
"Si consigues ser algo más que un hombre, si te entregas a un ideal, si nadie puede detenerte, te conviertes en algo muy diferente."
Visita piggypon.com
  #3 (permalink)  
Antiguo 27/08/2012, 06:50
 
Fecha de Ingreso: abril-2012
Mensajes: 65
Antigüedad: 10 años, 2 meses
Puntos: 0
Respuesta: Problema al pasar variables por URL al migrar de Xampp 1.7 a 1.8

Cita:
Iniciado por mortiprogramador Ver Mensaje
<saludos>
Y cual es el valor de $usuario?
De donde se obtiene???

Por otra parte, si puede ser un error de programación, falta la palabra php
en el tag de inicio de código php, y se escribe verSiÓn
Revisa eso
</saludos>

Que tal, gracias por responder

1.- encontré innecesario escribir los tag, solo la línea de código, pero acá va la pagina completa. la pagina es el mu luego del login donde el usuario ingresa su "usuario"

Código PHP:
<?
$usuario 
$_GET["usuario"]; 

echo 
" Menu Administrador (Mantenedor)<br>";
echo 
"<ul>";
echo 
"<li><a href='agregar_personal.php?usuario=$usuario'>AGREGAR Personal</a></li><br>";
echo 
"</ul>"
echo 
"<ul>";
echo 
"<li><a href='remover_personal.php?usuario=$usuario'>REMOVER Personal</a></li><br>";
echo 
"</ul>";   

?>
Saludos!

pd: como decia en este momento estoy en un pc con la vercion 1.7 de xampp y funciona correctamente y en otro con easyphp 5.3 tambien funciona.

pero en xamp 1.8 y easyphp 12 no hay caso con pasar las variables de esa forma.
  #4 (permalink)  
Antiguo 01/09/2012, 14:16
Avatar de mortiprogramador
Colaborador
 
Fecha de Ingreso: septiembre-2009
Ubicación: mortuoria
Mensajes: 3.805
Antigüedad: 12 años, 10 meses
Puntos: 214
Respuesta: Problema al pasar variables por URL al migrar de Xampp 1.7 a 1.8

<saludos>
Pues el código del primer post no se parece al código más reciente que enviaste.... y sin embargo en ambos el error es de programación

Haz lo que te dije desde un principio y verás que funciona
En mi caso acabe de bajar la versión de xampp 1.8 y he probado
corrigiendo lo que yo comenté en mi primera respuesta, y funciona.

Ha, y de nuevo, es verSiÓn

</saludos>
__________________
"Si consigues ser algo más que un hombre, si te entregas a un ideal, si nadie puede detenerte, te conviertes en algo muy diferente."
Visita piggypon.com

Última edición por mortiprogramador; 01/09/2012 a las 17:12

Etiquetas: 1-8, migrar, mysql, url, variables, xampp, usuarios
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 06:55.