Foros del Web » Administración de Sistemas » LAMP »

Problema: Zend Optimizer not installed

Estas en el tema de Problema: Zend Optimizer not installed en el foro de LAMP en Foros del Web. Hola amigos y amigas. He llevado un proceso para codificar mi código PHP para un cliente que necesita una aplicación que se ejecutará como Localhost. ...
  #1 (permalink)  
Antiguo 18/09/2011, 16:41
Avatar de ghidalgoram  
Fecha de Ingreso: marzo-2008
Ubicación: Costa Rica
Mensajes: 445
Antigüedad: 12 años, 7 meses
Puntos: 7
Pregunta Problema: Zend Optimizer not installed

Hola amigos y amigas.

He llevado un proceso para codificar mi código PHP para un cliente que necesita una aplicación que se ejecutará como Localhost.

Estoy usando Zend Optimizer. Instalé esta aplicación y realicé los pasos de configuración en varias ocasiones pero al ejecutar la aplicación con Wampserver me aparece la siguiente pantalla.



Le agradezco alguno si me puede orientar para resolver este problema.
Gracias amigos y amigas.
__________________
Loading...
  #2 (permalink)  
Antiguo 18/09/2011, 19:19
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 10.096
Antigüedad: 12 años, 2 meses
Puntos: 2231
Respuesta: Problema: Zend Optimizer not installed

Lamentablemente, no hay una version de Zend Optimizer para integrar con PHP 5.3.x, solo abarca desde 4.2.x hasta 5.2.x, por lo que deberias usar Zend Guard Loader como decodificador en tiempo de ejecucion, desde la pagina de descargas de Zend.
__________________
- León, Guanajuato
- GV-Foto
  #3 (permalink)  
Antiguo 19/09/2011, 12:36
Avatar de ghidalgoram  
Fecha de Ingreso: marzo-2008
Ubicación: Costa Rica
Mensajes: 445
Antigüedad: 12 años, 7 meses
Puntos: 7
Respuesta: Problema: Zend Optimizer not installed

Cita:
Iniciado por Triby Ver Mensaje
Lamentablemente, no hay una version de Zend Optimizer para integrar con PHP 5.3.x, solo abarca desde 4.2.x hasta 5.2.x, por lo que deberias usar Zend Guard Loader como decodificador en tiempo de ejecucion, desde la pagina de descargas de Zend.
Hola amigo. Gracias por tu gran ayuda.

Ingresé a la página de Zend y descargué el "Zend Guard Loader" ("ZendGuardLoader-php-5.3-Windows").

Lo abrí y tiene un archivo '.dll' llamado "ZendLoader.dll". Por favor, me podrías orientar como configurar este archivo para decodificar el código y ejecutarlo como Localhost (ya sea con Wampserver ó Xampp).

Te lo agradecería una vez más, ya que tengo semenas de estar probando y buscando formas de ejecutarlo correctamente.

Gracias, saludos.
__________________
Loading...
  #4 (permalink)  
Antiguo 19/09/2011, 13:42
Avatar de Triby
Mod on free time
 
Fecha de Ingreso: agosto-2008
Ubicación: $MX->Gto['León'];
Mensajes: 10.096
Antigüedad: 12 años, 2 meses
Puntos: 2231
Respuesta: Problema: Zend Optimizer not installed

No estoy seguro de que hayas descargado el archivo correcto, segun las notas de publicacion (release-notes.txt):

Cita:
============================
3. Installation Instructions
============================

Windows
-------
Double-click on the self-extracting archive, and follow the instructions in the
automated installation wizard.
Se trata de un comprimido ejecutable de auto extraccion y, que de paso, ejecutara el instalador... es decir, no tienes que abrirlo con winRar o similares, simplemente doble click.
__________________
- León, Guanajuato
- GV-Foto
  #5 (permalink)  
Antiguo 20/09/2011, 07:41
Avatar de ghidalgoram  
Fecha de Ingreso: marzo-2008
Ubicación: Costa Rica
Mensajes: 445
Antigüedad: 12 años, 7 meses
Puntos: 7
Sonrisa Respuesta: Problema: Zend Optimizer not installed

Hola Triby.

Te comento que la descarga del "Zend Guard Loader" la realicé desde el siguiente link http://www.zend.com/en/products/guard/runtime-decoders Es requerido tener una cuenta de usuario y loguearse en el sitio web de Zend.

Estaba leyendo un archivo "Readme.txt" y estas son las instrucciones que vienen. Trataré de seguirlas paso a paso, esperando que todo salga muy bien.


Cita:
Zend Guard Loader installation instructions
-------------------------------------------

1. Extract the Zend Loader package.

2. Locate and extract the ZendGuardLoader.so (Linux) or ZendLoader.dll (Windows) that corresponds to your php version.

3. Add the following line to your php.ini file for loading the ZendGuardLoader:
Linux and Mac OS X: zend_extension=<full_path_to_ZendGuardLoader.so>
Windows non-thread safe: zend_extension=<full_path_to_ZendLoader.dll>

4. Add an aditional line to your php.ini for enabling ZendGuardLoader
; Enables loading encoded scripts. The default value is On
zend_loader.enable=1

5. Optional: following lines can be added your php.ini file for ZendGuardLoader configuration:

; Disable license checks (for performance reasons)
zend_loader.disable_licensing=0
; The Obfuscation level supported by Zend Guard Loader. The levels are detailed in the official Zend Guard Documentation. 0 - no obfuscation is enabled
zend_loader.obfuscation_level_support=3
; Path to where licensed Zend products should look for the product license. For more information on how to create a license file, see the Zend Guard User Guide
zend_loader.license_path=

6. If you use Zend debugger as well, please make sure to load it after the Zend guard Loader

7. If you use ioncube loader, please make sure to load it before Zend guard Loader

8. Restart your Web server.
El Wampserver que instalé tiene:

Cita:
WampServer 2.1a [24/12/10]
Includes :
- Apache 2.2.17
- Php 5.3.3
- Mysql 5.1.53 (version 64 bits)
- Mysql 5.5.8 (version 32 bits)
- PhpMyadmin 3.2.0.1
- SQLBuddy 1.3.2

(a la fecha 20/09/2011)


Saludos Triby y amigos. Les comentaré como me fué.
Gracias.
__________________
Loading...
  #6 (permalink)  
Antiguo 20/10/2011, 15:56
 
Fecha de Ingreso: febrero-2004
Mensajes: 1.975
Antigüedad: 16 años, 8 meses
Puntos: 20
Respuesta: Problema: Zend Optimizer not installed

Yo nunca he podido correr GUARD con php 5.3

Mi php.ini esta así:

Cita:
[Zend]
zend_extension="C:\PHP\ext\ZendLoader.dll";
zend_loader.enable=1
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:41.