Foros del Web » Administración de webs » Servidores Web » Paquetes tipo LAMP »

problemas con wampserver y postgres

Estas en el tema de problemas con wampserver y postgres en el foro de Paquetes tipo LAMP en Foros del Web. hola a todos: bueno esta es mi duda y espero q me puedan ayudar, estoy utilizando wampserver 2.0 y necesito hacer una aplicación con postgres, ...
  #1 (permalink)  
Antiguo 29/06/2010, 07:28
 
Fecha de Ingreso: junio-2010
Mensajes: 19
Antigüedad: 4 años, 1 mes
Puntos: 0
Sonrisa problemas con wampserver y postgres

hola a todos:
bueno esta es mi duda y espero q me puedan ayudar, estoy utilizando wampserver 2.0 y necesito hacer una aplicación con postgres, el punto es q m sale un error, q no reconoce pg_connect, ya busque en otros foros y solo aparece q debo descomentar "extension=php_pgsql.dll", pues ya lo hize y nada aun m persiste el error, si alquien me podría ayudar la verdad soy nueva en esto, gracias
  #2 (permalink)  
Antiguo 29/06/2010, 08:13
Avatar de spider_boy  
Fecha de Ingreso: diciembre-2003
Ubicación: Chile
Mensajes: 1.857
Antigüedad: 10 años, 8 meses
Puntos: 88
Respuesta: problemas con wampserver y postgres

Creo que me pasó algo parecido.

Intenta lo siguiente :

Ve a la carpeta donde tienes instalado PostgreSQL, ve a la carpeta lib, y allí busca el archivo libpq.dll. Cópialo, y pégalo en la carpeta de PHP, en la carpeta principal. Luego ve a tu archivo httpd.conf, y agrega esta línea, dónde gustes :

Código PHP:
Ver original
  1. LoadFile "C:/PHP/libpq.dll"

O, pones la ruta absoluta al archivo dentro de la carpeta de PostgreSQL :

Código PHP:
Ver original
  1. LoadFile "C:/Archivos de programa/PostgreSQL/8.4/bin/libpq.dll"

Luego reinicias apache, y ves si te funciona.

Espero te sirva. Nos vemos .
__________________
Nunca te olvidaré mi negra hermosa. Te extraño demasiado.
  #3 (permalink)  
Antiguo 29/06/2010, 13:27
Avatar de GatorV
$this->role('moderador');
 
Fecha de Ingreso: mayo-2006
Ubicación: /home/ams/
Mensajes: 38.522
Antigüedad: 8 años, 3 meses
Puntos: 2108
Tema movido desde PHP a Paquetes tipo LAMP
  #4 (permalink)  
Antiguo 05/07/2010, 07:16
 
Fecha de Ingreso: junio-2010
Mensajes: 19
Antigüedad: 4 años, 1 mes
Puntos: 0
Respuesta: problemas con wampserver y postgres

muchas gracias pero creo q ya encontre la solucion para los q les pasó lo mismo: pues copie todos los .dll de la ubicación de postgres y lo pegue en la carpeta del apache y en System32, reinicie el apache y en el wamp habilite las opciones q son de postgres y listo!!!! ojala les sirva de algo

saludos

Etiquetas: postgresql
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:54.
SEO by vBSEO 3.3.2