Foros del Web » Programando para Internet » ASP Clásico »

Consulta que no inserta desde el command, pero si la imprimo y la ejecuto, si guarda

Estas en el tema de Consulta que no inserta desde el command, pero si la imprimo y la ejecuto, si guarda en el foro de ASP Clásico en Foros del Web. Buenos días foreros! Mi problema es el del título. Tengo una página que procesa unos datos y realiza un insert a la db mediante un ...
  #1 (permalink)  
Antiguo 19/10/2010, 07:19
Avatar de verinchi  
Fecha de Ingreso: septiembre-2004
Ubicación: Buenos Aires
Mensajes: 647
Antigüedad: 17 años, 8 meses
Puntos: 2
Consulta que no inserta desde el command, pero si la imprimo y la ejecuto, si guarda

Buenos días foreros!

Mi problema es el del título. Tengo una página que procesa unos datos y realiza un insert a la db mediante un objeto command.
Mi problema es que le doy a objcm.execute() y nada.

Para verificar qué era lo que estaba fallando, le di la orden de imprimir en pantalla lo que estaba intentando enviar a la db a ver si faltaba algo... una coma... esas cosas que suelen pasarse por alto y nos complican la existencia.
Pero para mi sorpresa, si copio el texto que se imprime de la pantalla y lo pego en una consulta en el sql, inserta los datos lo más bien!
Y lo peor de todo, es que desde asp imprime la consulta, hace que ejecuta y no da ningún error... realmente no se a que puede deberse. A alguien le pasó algo similar? Tienen idea de qué puede ser lo que produce este error?

Cabe aclarar también que sobre esa base de datos ya hay desarrollado un montón de cosas que funcionan barbaro. Comandos que insertan datos, objetos recordset para mostrarlos... hasta el momento todo está funcionando y estable.

Desde ya, gracias a quien pueda hechar un poco de luz a mi tema.
__________________
Why can't we not be sober?
www.partitorium.com.ar
  #2 (permalink)  
Antiguo 19/10/2010, 10:21
Avatar de Myakire
Colaborador
 
Fecha de Ingreso: enero-2002
Ubicación: Centro de la república
Mensajes: 8.849
Antigüedad: 20 años, 4 meses
Puntos: 146
Respuesta: Consulta que no inserta desde el command, pero si la imprimo y la ejecuto,

Tienes un on error?

Quizá la conexión es la que esta mal
  #3 (permalink)  
Antiguo 19/10/2010, 10:35
Avatar de verinchi  
Fecha de Ingreso: septiembre-2004
Ubicación: Buenos Aires
Mensajes: 647
Antigüedad: 17 años, 8 meses
Puntos: 2
Respuesta: Consulta que no inserta desde el command, pero si la imprimo y la ejecuto,

Cita:
Iniciado por Myakire Ver Mensaje
Tienes un on error?

Quizá la conexión es la que esta mal

Hola Myakire!
Bueno, en realidad no se que pudo pasar, pero luego de darle varias vueltas con un compañero aquí en el trabajo, cambiamos ADODB por Adodb en la declaración del objeto, y dejó de hacer lío.

Tenía manejadores de error pero los saltaba a todos, así que nada... no me lo explico pero por lo menos ya se solucionó.

__________________
Why can't we not be sober?
www.partitorium.com.ar

Etiquetas: inserta
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:51.