Foros del Web » Creando para Internet » Flash y Actionscript »

2 problemas, loadmovie y loading

Estas en el tema de 2 problemas, loadmovie y loading en el foro de Flash y Actionscript en Foros del Web. tengo dos problemas, que igual y son fáciles, pero pos no doy... El primero, tengo un loading, y funciona perfecto, pero de esta página (digamos ...
  #1 (permalink)  
Antiguo 20/03/2007, 00:12
 
Fecha de Ingreso: enero-2005
Mensajes: 90
Antigüedad: 12 años, 11 meses
Puntos: 0
Exclamación 2 problemas, loadmovie y loading

tengo dos problemas, que igual y son fáciles, pero pos no doy...

El primero, tengo un loading, y funciona perfecto, pero de esta página (digamos index) llamo a otras películas (loadmovie) y en estas ultimas el loading no funciona, este es el código:

Código:
function cargando() {
   var total, cargados, porcentaje;
   total = _root.getBytesTotal(229);
   cargados = _root.getBytesLoaded();
   porcentaje = Math.floor((cargados*100)/total);
   porcentaje_txt.text = porcentaje + " %";
   barra_mc.gotoAndStop(porcentaje);
   if (cargados == total) {
      clearInterval(hiloPrecarga);
      //Iniciar la pelicula
      play();
   }
}


var hiloPrecarga = setInterval(cargando, 1);

stop();
Y el 2º es que tengo una película inicial (index) llamo a otra película (subpágina) en un MC vacío con load movie hasta aquí todo bien, pero quiero llamar a otra película dentro de la subpágina por medio de un botón dentro de esta misma

Pueden checar lo que quiero en http://usuarios.lycos.es/jirso/ (es la página de la que hablo (por cierto se aceptan sugerencias) en el botón de la derecha hasta abajo "vívelo")

gracias de antemano por su ayuda, Vie! (bye)

Saludos.
  #2 (permalink)  
Antiguo 20/03/2007, 12:52
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: 2 problemas, loadmovie y loading

Hola jyrzo:
En el primer frame de la película que quieres cargar dentro de subpágina, coloca éste código: this._lockroot = true;

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 20/03/2007, 14:13
 
Fecha de Ingreso: enero-2005
Mensajes: 90
Antigüedad: 12 años, 11 meses
Puntos: 0
Re: 2 problemas, loadmovie y loading

Gracias bandit

Si es la solución que buscaba, alguna idea con el otro problemilla???
  #4 (permalink)  
Antiguo 20/03/2007, 18:47
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: 2 problemas, loadmovie y loading

Para cargar otra película dentro de subpágina, simplemente coloca un MC_vacío con nombre de instancia: contenedor.
Código para el botón:
on(release){
contenedor.loadMovie("nombre.swf");
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 21/03/2007, 00:22
 
Fecha de Ingreso: enero-2005
Mensajes: 90
Antigüedad: 12 años, 11 meses
Puntos: 0
Re: 2 problemas, loadmovie y loading

????

lo del loadmovie ya lo resolví gracias a tu aportación Bandit (bueno ya me lo resolviste, gracias)

Ahora aun no se como hacer lo del primer problema que planteo:

Es decir que mi loading no funciona mas que en la página principal, en todas las de mas que cargo (con el loadmovie) no funciona, no se ve que avance y no muestra el % real que ha cargado


Gracias por su colaboración y ayuda

Saludos
  #6 (permalink)  
Antiguo 21/03/2007, 10:06
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: 2 problemas, loadmovie y loading

En mi primer post te expliqué lo que tienes que hacer, léelo con más cuidado.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #7 (permalink)  
Antiguo 22/03/2007, 01:41
 
Fecha de Ingreso: enero-2005
Mensajes: 90
Antigüedad: 12 años, 11 meses
Puntos: 0
Sonrisa Re: 2 problemas, loadmovie y loading

Es cierto, no lo había observado, como también me solucionaba lo que puse como 2º problema...

O.K. ahora si me muestra el % real que ha cargado y funciona bien. Pero como de un botón de esta subpágina cargo en un MC vació del index al poner esta línea me deja de cargarlo y ya no funciona mi botón (espero explicarme)

ya que de la subpágina (en el boton) lo llamo con:

on(release) {
_root.llamando.loadMovie("nombre.swf");
}

y este lo cargo en la principal o index

(y al colocar el código que me comentas me hace que no funcione y no me cargue en el MC vacío ("llamando"))

Última edición por jyrzo; 22/03/2007 a las 01:46 Razón: error
  #8 (permalink)  
Antiguo 23/03/2007, 15:40
 
Fecha de Ingreso: enero-2005
Mensajes: 90
Antigüedad: 12 años, 11 meses
Puntos: 0
Re: 2 problemas, loadmovie y loading

.... Alguna idea??

me parece que la solució va a ser cargar las páginas tercearias en escenas, hay alguna forma de que las cargue mientras leen el resto de la página, para que no tarde tanto en cargarla (sobre todo en conexiones lentas)

Saludos
  #9 (permalink)  
Antiguo 26/03/2007, 16:20
 
Fecha de Ingreso: enero-2005
Mensajes: 90
Antigüedad: 12 años, 11 meses
Puntos: 0
Re: 2 problemas, loadmovie y loading

Si hay manera de que cargue lo demas mientras ve lo que ya cargo???
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:04.