Foros del Web » Creando para Internet » Flash y Actionscript »

acciones de boton erroneas

Estas en el tema de acciones de boton erroneas en el foro de Flash y Actionscript en Foros del Web. Hola, Tengo una web con una botonera metida en un movieclip. Los botones tienen la acción de gotoandplay a determinados frames de la escena principal, ...
  #1 (permalink)  
Antiguo 09/10/2007, 06:46
 
Fecha de Ingreso: junio-2007
Mensajes: 4
Antigüedad: 10 años, 6 meses
Puntos: 0
acciones de boton erroneas

Hola, Tengo una web con una botonera metida en un movieclip. Los botones tienen la acción de gotoandplay a determinados frames de la escena principal, pero curiosamente no funciona. Es decir, la acción la hace, pero no me manda al fotograma que yo quiero, sino 30 o 35 fotogramas antes o después de donde realmetne quiero que me mande. Y mientras más avanzo en la línea de tiempo, la diferencia se hace mayor con el nº real de frame al que quiero que me mande.

Esto ha hecho que tenga que hacer l abotonera sobre la línea de tiempo principal, y a causa de ello no puedo realizar ciertos cambios que me pide el cliente, por lo que tengo que averiguar por qué no me manda al fotograma que yo quiero.

Está realizada en Flash CS3 con Actionscript 2.0, por si sirve de algo.

Estoy a la espera de vuestras ideas!

Saludos!

Un beso.
  #2 (permalink)  
Antiguo 09/10/2007, 11:28
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Re: acciones de boton erroneas

Hola Charliechin:
Bienvenida al Foro.
Si estás usando AS 2
Coloca el código así:
on(release){
_root.gotoAndPlay(número_frame);
}

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 10/10/2007, 03:18
 
Fecha de Ingreso: junio-2007
Mensajes: 4
Antigüedad: 10 años, 6 meses
Puntos: 0
Re: acciones de boton erroneas

Hola!! Gracias por responder, pero esq ese es mi problema!

usando ese código, escribo (por ejemplo) 3 y en vez de a ese fotograma, me envia a otro cualquiera,como por ejemplo el 58. no tiene sentido!! toy cagao... a ver si alguien sabe por que me pasa eso.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 01:42.