Foros del Web » Creando para Internet » Flash y Actionscript »

¿Alguien me dice que hago mal..?

Estas en el tema de ¿Alguien me dice que hago mal..? en el foro de Flash y Actionscript en Foros del Web. Tengo problemas con un clip que tiene varios clips anidados. Busque en el foro 419 opciones de las cuales 2 tienen el mismo problema cuya ...
  #1 (permalink)  
Antiguo 18/05/2004, 20:13
 
Fecha de Ingreso: abril-2004
Mensajes: 6
Antigüedad: 13 años, 7 meses
Puntos: 0
¿Alguien me dice que hago mal..?

Tengo problemas con un clip que tiene varios clips anidados. Busque en el foro 419 opciones de las cuales 2 tienen el mismo problema cuya solucion no esta escrita.

El ejemplo mas practico es el de Clip "auto con ruedas girando".

Linea de tiempo principal = 1 frame : solo clip de auto sin ruedas.
Dentro de este clip -el del auto- estan anidadas otras peliculas: P.ej.ruedas, sonido bocina, chofer saludando, etc.

O sea 3 peliculas independientes con distintas lineas de tiempo.
Cada una tiene 20 frames, 30 y 40 frames respectivamente.

Pregunto:
¿Porque no me reproduce la totalidad de los frames de cada pelicula anidadas.
Solo consigo reproducir los clips cuando aumento la cantidad de frames en la linea de tiempo principal. En vez de 1 frame, pongo 20 por ejemplo.

¿Me pueden ayudar? Muchas gracias
Humildemente Mariano.
  #2 (permalink)  
Antiguo 18/05/2004, 21:05
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola MarianoIza:
Es raro lo que te sucede, porque cada MC trabaja en su propia línea de tiempo y no debería tener problemas al ponerlo en un sólo frame de la principal, podrías mostrar tu .fla para poderte ayudar mejor.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 18/05/2004, 21:19
Avatar de rusoftware  
Fecha de Ingreso: abril-2004
Ubicación: Rosario - Argentina
Mensajes: 1.083
Antigüedad: 13 años, 8 meses
Puntos: 2
Hola...

A ver si puedo ayudarte... Primero te pregunto: ¿esos MC anidados los cargas de la biblioteca?

porque de ser así, debes programarlos para la exportación!

Comento ésto porque yo estoy teniendo inconvenientes con el ejemplo de "añadir animación a todos los botones" y me encontré con ésto. Ten en cuenta que aún soy muy novato en el tema. pero quizás ésto pueda ser el problema.

Un abrazo
  #4 (permalink)  
Antiguo 19/05/2004, 20:24
 
Fecha de Ingreso: abril-2004
Mensajes: 6
Antigüedad: 13 años, 7 meses
Puntos: 0
es verdad que no tiene por que ocurrir...

(COMO PUEDO ENVIARTE EL .fla? )

Pero ocurre. Si le dejo un frame, las peliculas anidadas -que no son mas que animaciones de interpolacion de movimiento...nada raro.- o no se reproducen o reproducen solo una cantidad de cuadros x..generalmente menos de la mitad....

pero si aumento los frames del level 0 o la linea pincipal de tiempo, la pelicula va mejorando la reproduccion de frames de las otras pelis anidadas.

No tiene necesidad de ponerle acciones de fotograma ni nada raro...simplemente no reproduce la totalidad.
  #5 (permalink)  
Antiguo 19/05/2004, 21:16
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola Marianolza:
Envíame a esta dirección tu .fla [email protected]

Espero poderte ser de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 20:51.