Foros del Web » Creando para Internet » Flash y Actionscript »

ayuda......(..)

Estas en el tema de ayuda......(..) en el foro de Flash y Actionscript en Foros del Web. estoy enviando un parametro a flash en el momento que se carga con <object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="144" height="305"> <param name="movie" value="../flash/Administracion.swf? t1=1 "> <param name="wmode" ...
  #1 (permalink)  
Antiguo 20/02/2005, 10:18
Avatar de minguet1210  
Fecha de Ingreso: abril-2004
Ubicación: TEXAS
Mensajes: 47
Antigüedad: 13 años, 7 meses
Puntos: 0
ayuda......(..)

estoy enviando un parametro a flash en el momento que se carga con

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="144" height="305">
<param name="movie" value="../flash/Administracion.swf?t1=1">
<param name="wmode" value="transparent">
<param name="quality" value="high">
<embed src="../flash/Administracion.swf?t1=1" quality="high" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="144" height="305"></embed>
</object>

y en adentro de flash tengo la siquiente condicion

id = t1.text;
if ( id = "1"){
boton1._visible = false;
}

pero no se si esta vien la comparacion, ya que no funciona o es que no se realiza de esa manera..
__________________
MF.

Última edición por minguet1210; 20/02/2005 a las 10:20
  #2 (permalink)  
Antiguo 20/02/2005, 12:43
Avatar de goc00  
Fecha de Ingreso: enero-2002
Ubicación: 000's DiMensiOn
Mensajes: 979
Antigüedad: 15 años, 10 meses
Puntos: 3
La comparación debería ser así:

Código:
id = t1.text;
if (id) {
   boton1._visible = false;
}
= es un elemento de asignación; == es de comparación
__________________
GOC00 CominG soOn v2.0
CyA! & GooD LuCK...

Última edición por goc00; 20/02/2005 a las 12:45
  #3 (permalink)  
Antiguo 20/02/2005, 14:55
Avatar de minguet1210  
Fecha de Ingreso: abril-2004
Ubicación: TEXAS
Mensajes: 47
Antigüedad: 13 años, 7 meses
Puntos: 0
El problema no son el sino = eso fue un pelon cuando estaba tipiando

intende como me dices, pero de toda manera no sique diferencianto lo que resibe..

hay otra manera de enviarle mas de un parametro desde el exterior al interior de flash
que yo pueda enviar mas de una Variable.
t1,t2,t3..
__________________
MF.

Última edición por minguet1210; 20/02/2005 a las 14:57
  #4 (permalink)  
Antiguo 20/02/2005, 16:14
Avatar de minguet1210  
Fecha de Ingreso: abril-2004
Ubicación: TEXAS
Mensajes: 47
Antigüedad: 13 años, 7 meses
Puntos: 0
una Solución

Esta es una solución que se me ocurrio ya que de esta manera aseguro que el dato que comparo son iguales.


var id:String = t1.toString();
if (id == "0"){
boton1._visible = false;
}
__________________
MF.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 22:23.