Foros del Web » Creando para Internet » Flash y Actionscript »

ayuda con botones de musica

Estas en el tema de ayuda con botones de musica en el foro de Flash y Actionscript en Foros del Web. le he puesto musica a la web echa en flash mx explico lo que he echo pero no sale : tengo dos botones uno stop ...
  #1 (permalink)  
Antiguo 25/05/2005, 07:43
 
Fecha de Ingreso: septiembre-2003
Mensajes: 288
Antigüedad: 14 años, 2 meses
Puntos: 0
ayuda con botones de musica

le he puesto musica a la web echa en flash mx explico lo que he echo pero no sale :

tengo dos botones uno stop y otro play
en el stop le tengo puesto
on (press) {
stopAllSounds();
}
este si va bien
en el play:

on(press){
_root.mimusica.stop();
}
on(release){
_root.mimusica.start("20", 999);
}

este no hace ni p**o caso
y en un frame que es donde tengo el sonido le tengo puesto:

mimusica = new Sound();
mimusica.attachSound("mimusica");

alguien me podria decir que hay mal, no se si la musica la tengo que convertir en clip de pelicula y si es asi como lo tengo que hacer ?venga muchas gracias y un salu2.
  #2 (permalink)  
Antiguo 25/05/2005, 08:45
Avatar de luisch125  
Fecha de Ingreso: mayo-2005
Ubicación: Elche, Alicante
Mensajes: 632
Antigüedad: 12 años, 7 meses
Puntos: 3
Yo tengo una web y coloqué musica de la misma forma. El archivo tiene dos fotogramas. En ambos hay un stop, para que siempre este fija en uno de los fotogramas. Hice una capa para el fondo, otra para los botones y otra para la musica. En el primer fotograma, el boton play no tiene utilidad, pues la musica esta conectada por defecto. Pero el boton stop tiene el codigo:

on (release) {
gotoAndPlay(2);
}

En el fotograma 2, el fotograma tiene un

stopAllSounds();

Y el botón play en el fotograma 2 tiene un

on (release) {
gotoAndPlay(1);
}

Y ya está...
En el fotograma 2 el boton stop no necesita ningun codigo...

Un saludo
  #3 (permalink)  
Antiguo 25/05/2005, 13:30
 
Fecha de Ingreso: septiembre-2003
Mensajes: 288
Antigüedad: 14 años, 2 meses
Puntos: 0
gracias por contestar pero creo que como dices no lo puedo hacer por que mi archivo tiene 175 fotogramas.salu2.
  #4 (permalink)  
Antiguo 25/05/2005, 13:58
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Hola armengual:
Para cargar un sonido que está en la biblioteca tienes que poner éste código en el frame 1 de tu película:
sonido = new Sound();
sonido.attachSound("mimusica")
_root.sonido.stop();
_root.sonido.start(0, 999);
abres la biblioteca y le das con el botón derecho sobre el nombre del sonido y en la ventana que aparece le das a: Vinculación, ésto te abrirá otra ventana don de le pones como Identificador: mimusica y activas donde dice: {B]Exportar para ActionScript[/B] y Acepta.
Ahora para hacer los botones:
Crea un MC y en la capa 1 frame 1 coloca el botón con la palabra STOP y le pones éste código:
on (press) {
_root.sonido.stop();
_root.clip.gotoAndPlay (2);
}
En la capa 2 frame 2 coloca el botón START y le pones éste código:
on (release) {
_root.sonido.start(0, 999);
_root.clip.gotoAndPlay (1);
}
Crea la capa 3 y en los frames 1 y 2 coloca un stop();
El botón lo ubicas el el lugar que quieras en el escenario principal, no importa la cantidad de frames que tenga tu película.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/

Última edición por Bandit; 25/05/2005 a las 14:06
  #5 (permalink)  
Antiguo 25/05/2005, 14:03
Avatar de luisch125  
Fecha de Ingreso: mayo-2005
Ubicación: Elche, Alicante
Mensajes: 632
Antigüedad: 12 años, 7 meses
Puntos: 3
Bueno, tienes razon, perdona pero no cai que toda tu web era en flash...
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 21:51.