Foros del Web » Creando para Internet » Flash y Actionscript »

Ayuda con goto y variable!!!! Please!!!

Estas en el tema de Ayuda con goto y variable!!!! Please!!! en el foro de Flash y Actionscript en Foros del Web. Bueno, lo que quiero hacer es simplemente esto. Quiero que una variable tenga el nombre de una escena y poder hacer un gotoandplay(variable) y que ...
  #1 (permalink)  
Antiguo 18/03/2003, 08:40
 
Fecha de Ingreso: marzo-2003
Mensajes: 11
Antigüedad: 14 años, 8 meses
Puntos: 0
Ayuda con goto y variable!!!! Please!!!

Bueno, lo que quiero hacer es simplemente esto. Quiero que una variable tenga el nombre de una escena y poder hacer un gotoandplay(variable) y que valla a la escena que tiene almacenada esa variable.
Lo que yo hago es lo sig:

variable = "nombre_escena"
gotoandplay(variable)

Pero esto no me funciona. Lo estoy haciendo en flash 5.0. Espero que alguien me pueda ayudar, desde ya muchas gracias......

Mariano.
  #2 (permalink)  
Antiguo 18/03/2003, 09:48
 
Fecha de Ingreso: febrero-2003
Mensajes: 795
Antigüedad: 14 años, 10 meses
Puntos: 2
no le des nombres de escena, el problema con el flash, es que al convertirlo a swf las scenas dejan de existir, por lo que tienes que hacer es darle un nombre al primer deframe de tuescena, y en tu variable dale ese nombre (aunque en realidad no lo veo necesario ya, pero depende para que lo estes usando)

Saludos
__________________
Carlo Rodríguez
florerias en lima
  #3 (permalink)  
Antiguo 18/03/2003, 18:06
 
Fecha de Ingreso: marzo-2003
Mensajes: 11
Antigüedad: 14 años, 8 meses
Puntos: 0
Bueno muchas gracias por responderme. Probe con lo que me dijiste pero sigue sin andar.
Probe asi:

variable = "nombre_de_rotulo"
gotoandplay (variable)

Quiero hacer esto para lo siguiente. Yo desde una escena tengo un menu con 3 botones, entonces cuando apreto un boton guardo en la variable a donde tiene que ir despues de hacer unas animaciones, cuando termina las animaciones pongo una accion con un gotoandplay(variable) y entonces tendria que ir a donde yo le dije, pero no va. Nose que estoy haciendo mal, me parece que el tema es que cuando pongo el gotoandplay, en las opciones que aparecen abajo me pone la escena actual y el tipo como una expresion pero no se que hacer ya que tambien probe en modo experto y nada. Please ayuda.......... Gracias de todas formas.....

Mariano.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 19:10.