Foros del Web » Creando para Internet » Flash y Actionscript »

ayuda con gotoandplay()

Estas en el tema de ayuda con gotoandplay() en el foro de Flash y Actionscript en Foros del Web. buenas noches chicos, soy nuevo en el foro y en programacion flash. estoy haciendo un sitio web en flash cs5 con actionscript 2.0 y tengo ...
  #1 (permalink)  
Antiguo 02/09/2010, 01:16
 
Fecha de Ingreso: septiembre-2010
Mensajes: 6
Antigüedad: 11 años, 9 meses
Puntos: 0
Exclamación ayuda con gotoandplay()

buenas noches chicos, soy nuevo en el foro y en programacion flash.
estoy haciendo un sitio web en flash cs5 con actionscript 2.0 y tengo el siguiente problema...

en la esena2 de mi pelicula tengo un objeto clip de pelicula llamado "imagen" y un boton llamado "siguiente". lo que quiero hacer es dentro del objeto "imagen" poner distintas imagenes (una imagen por fotograma) y cada vez que oprimo el boton "siguiente" se me muestre una imagen distinta. probe con varios codigos como por ejemplo:

on(release){
gotoAndPlay("imagen",2);
}

pero en vez de mostrarme la imagen 2 me pasa al fotograma 2 pero de la esena y no de ese clip de pelicula....

no se si me estoy explicando bien pero necesito su ayuda...

muchas gracias
  #2 (permalink)  
Antiguo 02/09/2010, 06:26
Avatar de Jime25  
Fecha de Ingreso: septiembre-2009
Ubicación: Mi casa
Mensajes: 1.213
Antigüedad: 12 años, 9 meses
Puntos: 138
Respuesta: ayuda con gotoandplay()

Lo que tenés que hacer es ponerle al Clip de película un nombre de instancia (en el panel de propiedades), como por ejemplo "clip_mc". Entonces el código lo escribís así:

Cita:
on(release){
clip_mc.gotoAndPlay("imagen", 2);
}
Saludos!!
__________________
Jime~

Mi blog.
Mi twitter.
  #3 (permalink)  
Antiguo 02/09/2010, 13:18
 
Fecha de Ingreso: septiembre-2010
Mensajes: 6
Antigüedad: 11 años, 9 meses
Puntos: 0
Respuesta: ayuda con gotoandplay()

muchas gracias por tu pronta respuesta, creo que andas muy muy cerca de encontrar mi problema, se me soluciono el tema de que al hacer el gotoandplay se me habra en cualquier instancia... ahora no pasa nada cuando oprimo el boton, no se porque no se cambia de imagen. puse este codigo:

on(release){
clip_mi.gotoAndplay("galeria_imagen",6);
}

bueno en la esena 2 tengo un rectangulo que lo hice un clip de pelicula y lo llame "galeria_imagen", dentro de ese clip desde el fotograma 1 al 5 tengo una imagen que aparece primera siempre que inicio la pelicula. desde el fotograma 6 al 10 borre esa imagen y puse en su lugar otra, que es la que quiero que salga al oprimir un boton. pero cual oprimo el boton sigue la misma imagen, no se porque pasa esto.. espero puedan ayudarme. nombre a la instancia des rectangulo que muestra las fotos como "clip_mi".

te dejo como va la pagina para que se den una idea de como es el problema... tenes que hacer en inicio y desdues en galeria, te va a mostrar la primer imagen y y despues al darle al boton de siguiente no muestra la otra imagen... tarda un pokito en cargar y todabia no le hice un pre loader... ademas de que faltan opciones y arreglarla un poco..

www.ilusoft.com.ar/titon/pagina.swf

saludos

Última edición por tite88; 02/09/2010 a las 13:40

Etiquetas: gotoandplay
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 16:58.