Foros del Web » Creando para Internet » Flash y Actionscript »

ayuda con loadmovie

Estas en el tema de ayuda con loadmovie en el foro de Flash y Actionscript en Foros del Web. Hola: Tengo un escenario que se va armando paulatinamente, el ultimo frame tiene un Stop(). Dentro de la pelicula tengo varios botones y un MC ...
  #1 (permalink)  
Antiguo 17/05/2003, 16:09
pindyortiz
Invitado
 
Mensajes: n/a
Puntos:
Pregunta ayuda con loadmovie

Hola:

Tengo un escenario que se va armando paulatinamente, el ultimo frame tiene un Stop().
Dentro de la pelicula tengo varios botones y un MC vacio llamado Panel_MC

en un boton tengo el codigo:

on (rollOver) {
txt1 = "..:: Fotos ::..";
}
on (rollOut) {
txt1 = "";
}
on (release) {
panel_mc.loadMovie("luces.swf");
}

y lo que ocurre es que no funciona la pelicula luces.swf.
probe de muchas manera:
poniendo en MC vacio en otro layer, poniendolo en el ultimo frame, en penultimo frame, etc. Pero no me funciona, porque será????


Espero su ayuda....
  #2 (permalink)  
Antiguo 17/05/2003, 19:15
Avatar de hucasys  
Fecha de Ingreso: noviembre-2001
Ubicación: Bastante buena...
Mensajes: 816
Antigüedad: 16 años, 1 mes
Puntos: 3
¿Y así?
on (release) {
_root.panel_mc.loadMovie("luces.swf");
}

ya que según dices panel_mc está en la línea de tiempo principal...
__________________
La manera en que resuelves el problema, es el problema.
ROBERT FRIPP
  #3 (permalink)  
Antiguo 17/05/2003, 19:57
pindyortiz
Invitado
 
Mensajes: n/a
Puntos:
Tampoco funciona de esa manera.

Al principio pense que podia ser porque no definí el tamaño de MC vacío, pero lei en otro post que eso no importa porque el tamaño lo establece la pelicular que se carga en el mismo.
Intente de muchas maneras, lo que vi en varios post pero no me sale...
No se lo que estoy haciendo mal
  #4 (permalink)  
Antiguo 18/05/2003, 14:45
pindyortiz
Invitado
 
Mensajes: n/a
Puntos:
Vamos mejor!!!

Ahora carga la pelicula luces.swf, pero se descarga la pelicula principal y por lo tanto la pelicula secundaria no aparece en la posicion deseada.
El codigo actual es:

loadmovie("luces.swf",panel_mc);

pero no logro que la pelicula anterior quede detras.

por favor ayudenme, es importante.

tambien probé con

_root.panel_mc.loadmovie("luces.swf");

y directamente no carga nada...
  #5 (permalink)  
Antiguo 18/05/2003, 15:45
pindyortiz
Invitado
 
Mensajes: n/a
Puntos:
yo de nuevo :(

Mira maltos, lei el post querido movieclip y segun la explicaciones que hay ahi, creo que he hecho lo correcto.

mi pelicula principal se va armando con una serie de animaciones, en el ultimo frame, el numero 63 se cargan 6 botones, ademas ese frame tiene el codigo:

Stop();

el frame con el MC vacio llamado panel_mc, lo cargue en el frame 62.

luego un boton probe todos los codigos que estan en los post anteriores, pero ninguno funciona como deseo.
se debe cargar una pelicula "luces.swf" en una parte de la pelicula principal, seria al costado derecho, pero a veces con algunos codigos no la carga, y con otros codigos cuando lo hace la pelicula anterior que tiene el fondo se descarga.

la otra pelicula que debe cargar, "luces.swf", tiene tambien unas animacines y el ultimo frame el codigo

stop();

y es ese mismo ultimo frame aparece un boton que tiene una sentencia para descargar, pero esto todavia no funciona porque la pelicula no se cargar correctamente.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 10:12.