Foros del Web » Creando para Internet » Flash y Actionscript »

Ayuda con LOADMOVIE

Estas en el tema de Ayuda con LOADMOVIE en el foro de Flash y Actionscript en Foros del Web. Saludos amigos soy nuevo por aquí como muchos otros, y me ha traído la duda sobre el comando "Loadmovie" Yo lo estoy usando en Swishmax2 ...
  #1 (permalink)  
Antiguo 21/09/2008, 21:42
 
Fecha de Ingreso: septiembre-2008
Mensajes: 3
Antigüedad: 9 años, 2 meses
Puntos: 0
Pregunta Ayuda con LOADMOVIE

Saludos amigos soy nuevo por aquí como muchos otros, y me ha traído la duda sobre el comando

"Loadmovie"


Yo lo estoy usando en Swishmax2


Mi problema es el siguiente:

Tengo 3 archivos .SWF cada uno cuenta con su PRELOADER

El primero es la base de la pagina, llamémoslo 1.swf 2.swf 3.swf (no son los nombres reales)

1.SWF < aquí se carga todo desde el principio

Dentro de este tengo un Container que llama a un archivo externo este seria el
2.SWF dentro de este se despliegan varios botones. Hasta alli perfecto, este archivo 2.SWF también llama otro archivo externo que sería el 3.SWF

Pero cuando le doy al botón que debería llamar y traer el archivo externo 3.SWF. Me regresa al principio del 1.SWF y no carga el archivo 3.SWF

Como podrán ver soy novato en esto y quisiera ver donde esta el error. Les copio y pego los códigos:


onFrame (95) {
stopSound ("BNt.WAV");
Container.unloadMovie();
ContainerII.unloadMovie();
ContainerII.loadMovie ("productos.swf")
}

-----------------
Cuando carga producto dentro del containerII, lo hace sin problema en la base del Flash. Luego productos.swf tiene un botón con el siguiente comando:

Boton comando:


on (rollOver) {
this.gotoAndPlay(73);
}
on (rollOut) {
this.gotoAndPlay(71);
}
on (press) {
gotoSceneAndPlay("Acc", 100);
}

------------------------------------------------------------
Scene "Acc"



onFrame (100) {
Cargador.unloadMovie();
Cargador.loadMovie ("Maniquis.swf")
}

Aquí es donde me da un error, porque el archivo "Maniquis.SWF" debería de cargarse dentro del container del archivo "productos.swf" pero cuando le doy al botón que me debería de cargar, me manda al primer frame de la base del flash.

Que pudiera estar causando eso? cuantas veces se puede usar este comando dentro de una película Flash?

Gracias de antemano a los eruditos en el tema

SALUDOS
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 09:00.