Foros del Web » Creando para Internet » Flash y Actionscript »

Ayuda por favoooorrr!!!

Estas en el tema de Ayuda por favoooorrr!!! en el foro de Flash y Actionscript en Foros del Web. Hola a todos!!! Necesito ayuda, tengo un problema con un sitio que estoy armando en flash. El sitio es de diseño, y es para mostrar ...
  #1 (permalink)  
Antiguo 04/07/2007, 15:33
 
Fecha de Ingreso: diciembre-2006
Mensajes: 15
Antigüedad: 11 años
Puntos: 0
De acuerdo Ayuda por favoooorrr!!!

Hola a todos!!!
Necesito ayuda, tengo un problema con un sitio que estoy armando en flash.
El sitio es de diseño, y es para mostrar trabajos realizados por mi estudio. Por cada cliente tengo una pelicula que es llamada desde una pelicula base, y según el área en que esté se van abriendo distintos trabajos.
Si entro en el area de web, se me abren todos los clientes de web y si presiono en uno de ellos llama a la pelicula que corresponde al cliente posicionandose en el trabajo que se pide, en este caso web. En la película del cliente tengo en distintos fotogramas cada trabajo y desde el botón del cliente le especifico a que fotograma tiene que ir con el siguiente codigo:

on(release){
clip_mc = this.createEmptyMovieClip("holder", 1);
clip_mc._x = -170
clip_mc._y = -335
clip_mc.loadMovie("bn.swf");
this.onEnterFrame = function() {
if (clip_mc.getBytesLoaded() != 0 && clip_mc.getBytesLoaded() == clip_mc.getBytesTotal()) {
clip_mc.gotoAndPlay(20);
//aquí va el número del frame donde se quiere ir
delete this.onEnterFrame;
}
};
}

el problema es que cuando carga el swf me carga primero el 1 fotograma y despues va al fotograma indicado.
Otro problema que tengo es que en la pelicula a la que llamo tiene un cargador en el primer fotograma y cuando carga la pelicula se carga el cargador a medias y despues se vuelve a cargar en la mitad de la animación.

Alguien puede decirme que estoy haciendo mal!!!
El link de mi página es: www.dispares.com.ar
Gracias!!!!

Jessica
  #2 (permalink)  
Antiguo 04/07/2007, 21:25
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
Re: Ayuda por favoooorrr!!!

pues no pongas nada en el primer fotograma y asi no te aparecera nada. y aparte checa si es
Código:
clip_mc.gotoAndPlay(20);
ó

Código:
clip_mc.gotoAndStop(20);.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 11:40.