Foros del Web » Creando para Internet » Flash y Actionscript »

Ayuda¡¡¡ problemas con _parent

Estas en el tema de Ayuda¡¡¡ problemas con _parent en el foro de Flash y Actionscript en Foros del Web. Hola compañeros, he estado mirando detenidamente los FAQ para intentar resolverlo, pero tras horas y horas no cosigo tenerlo claro aver si me pueden ayudar. ...
  #1 (permalink)  
Antiguo 04/08/2005, 15:53
Avatar de halukar  
Fecha de Ingreso: julio-2005
Ubicación: España, Madrid
Mensajes: 1.642
Antigüedad: 12 años, 5 meses
Puntos: 5
Exclamación Ayuda¡¡¡ problemas con _parent

Hola compañeros, he estado mirando detenidamente los FAQ para intentar resolverlo, pero tras horas y horas no cosigo tenerlo claro aver si me pueden ayudar.

Tengo dos películas, la primera se llama "informacion.swf" donde hay un MC llamado "texto" k se mueve verticalmente mediante cuatro botones (dos para subir seguido uno del otro y dos para bajar de la misma manera )
Los fotogramas donde se situan tienen un nombre, y los botones estas acciones:


up1 (nombre de fotograma)

on (rollOver) {
tellTarget ("/texto") {
prevFrame();
}
gotoAndStop("up2");
}

up2 (nombre del fotograma)

on (rollOver) {
tellTarget ("/texto") {
prevFrame();
}
gotoAndPlay("up1");
}

down1 (nombre del fotograma)

on (rollOver) {
tellTarget ("/texto") {
nextFrame();
}
gotoAndStop("down2");
}

down2 (nombre del fotograma)

on (rollOver) {
tellTarget ("/texto") {
nextFrame();
}
gotoAndPlay("down1");
}

Bien todo esto se refiere a la primera película donde está el MC de texto con los botones k hacen de scroll. Funciona perfectamente pero al cargarlo con loadMovie dentro del MC "base" de otra película, (principal.swf) no funciona el scroll de botones y me aparece el siguiente error repetido varias veces

Destino no encontrado: Destino="/texto" Base="_level0.base"

Supongo k es xq no encuentra la ruta y busca el MC en la película principal.swf

Necesito usar _parent? como lo hago? no veo la forma de como ni donde colocarlo


La segunda película k también me funciona bién hasta k la cargo x loadMovie dentro del MC "base" de principal.swf es un visor de recetas con texto e imagen usando XML y loadMovie. En este caso funciona a medias, el texto aparece pero la imagen o no aparece o aparece en las eskinas de la película principa fuera del MC.

Creo k estas son las líneas de código k deben de modificarse. También lo intentado con _parent, he conseguido k aparezcan pero no en las cordenadas k deberían de estar.

_root.createEmptyMovieClip("proyector",1000);
proyector._x = 290;
proyector._y = 70;
proyector.loadMovie(IImagen);
// control navegación: indica el numero de la receta que se visualiza
// del total existentes
vRecetaActual = 1;
tContador = vRecetaActual+" de "+vTotal;
//mEstado.gotoAndStop(2);
} else {

//mEstado.gotoAndStop(1);
tReceta = "Error. No se pudo cargar la receta";
}
}
//--------------------------------------------------------------------------
// boton siguiente
boton_siguiente.onRelease = function() {
if (vRecetaActual<vTotal) {
vRecetaActual += 1;
tTitulo = aTitulo[vRecetaActual-1];
tIngredientes = aIngredientes[vRecetaActual-1];
tPreparacion= aPreparacion[vRecetaActual-1];
IImagen = aImagen[vRecetaActual-1];
tContador = vRecetaActual+" de "+vTotal;
proyector.loadMovie(IImagen);
}
};
//---------------------------------------------------------------------------
// boton anterior
boton_anterior.onRelease = function() {
if (vRecetaActual>1) {
vRecetaActual -= 1;
tTitulo = aTitulo[vRecetaActual-1];
tIngredientes = aIngredientes[vRecetaActual-1];
tPreparacion= aPreparacion[vRecetaActual-1];
IImagen = aImagen[vRecetaActual-1];
tContador = vRecetaActual+" de "+vTotal;
proyector.loadMovie(IImagen);
}
};



Perdonar por lo larguísimo del mensaje, intenté subir los archivos .fla ami servidor pero me está dando fallos al bajarlos, si alguién kiere echarles un vistazo k deje el email y se los mando.

Muchusímas gracias d antemano, me tiene bastante rayado esto y me gustaría poder entenderlo.
__________________
"Soy aquello que quiso ser alguien y acabo siendo nadie"

DALI00.es
El renacer del surrealismo (coming soon)
  #2 (permalink)  
Antiguo 04/08/2005, 17:13
Avatar de dexter_x740  
Fecha de Ingreso: julio-2003
Ubicación: cd. obregon, Sonora
Mensajes: 246
Antigüedad: 14 años, 4 meses
Puntos: 1
bueno puedo ayudarte con la primera parte de codigo. para empezar no uses tellTarget, ya no se usa, mejor has referencia a los objetos con puntos, por ejemplo para que se solucione tu problema, en la parte de los botones hasle asi:
Código PHP:
on (rollOver) {
_parent.texto.nextFrame();

__________________
[D3X73®]
  #3 (permalink)  
Antiguo 04/08/2005, 19:00
Avatar de halukar  
Fecha de Ingreso: julio-2005
Ubicación: España, Madrid
Mensajes: 1.642
Antigüedad: 12 años, 5 meses
Puntos: 5
Hola dexter_x740, gracias x ayudarme probe tu código pero no me funciono, con el ".texto" a k te refieres a el MC texto o es un sustituto de tellTarget ?

gracias
__________________
"Soy aquello que quiso ser alguien y acabo siendo nadie"

DALI00.es
El renacer del surrealismo (coming soon)
  #4 (permalink)  
Antiguo 04/08/2005, 20:24
Avatar de halukar  
Fecha de Ingreso: julio-2005
Ubicación: España, Madrid
Mensajes: 1.642
Antigüedad: 12 años, 5 meses
Puntos: 5
dexter_x740, ya entendi lo k deciste, le estado dando vueltas a la segunda película y ya se como hacerla funcionar, pero aun sigo con la primera k no funciona al cargala desde fuera.

Si alguien me puede sugerir algo? gracias
__________________
"Soy aquello que quiso ser alguien y acabo siendo nadie"

DALI00.es
El renacer del surrealismo (coming soon)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 12:56.