Foros del Web » Creando para Internet » Flash y Actionscript »

Basica sobre email en flash

Estas en el tema de Basica sobre email en flash en el foro de Flash y Actionscript en Foros del Web. Hola, tengo un formulario de email basico hecho en html que lo envio a un CGI gratuito de mi hosting y recibo emails normalmente. Hasta ...
  #1 (permalink)  
Antiguo 15/03/2006, 06:13
Avatar de Pablus00  
Fecha de Ingreso: diciembre-2003
Ubicación: A un click de distancia
Mensajes: 1.044
Antigüedad: 14 años
Puntos: 11
Exclamación Basica sobre email en flash

Hola, tengo un formulario de email basico hecho en html que lo envio a un CGI gratuito de mi hosting y recibo emails normalmente.

Hasta ahi todo bien, ahora cuando quiero usar un formulario en flash no me funciona.

esto es parte del codigo del formulario en html
<INPUT name="pablo" type=text> ...... el resto de sus campos aqui
<br><br>Email : <input type=text name="email">

segun para enviar un formulario en flash tengo que crear campos con introduccion de texto, y ponerle que envien variables con el mismo nombre que utilizo en este formulario para mis campos, o sea "email" y "pablo"

en el boton de envio puse:
on (release) {
getURL("http://www.misitioweb.com/cgi-bin/FormMail.cgi", vars=POST);
}

y no me llega , que hice mal?
__________________
-- Nunca te des por vencido, aún vencido -- Web
  #2 (permalink)  
Antiguo 15/03/2006, 07:03
Avatar de andrewp  
Fecha de Ingreso: agosto-2003
Ubicación: Barcelona
Mensajes: 1.160
Antigüedad: 14 años, 3 meses
Puntos: 5
Pablo... Te aconsejo que sigas la guía que un moderador ha dejado publicada en las FAQ's de Flash (Cliquéa aquí)... Siguiendo el ejemplo podrás verificar si tienes errores en tu formulario Flash ó en las líneas PHP.

Saludos!
__________________
Andrew :P
  #3 (permalink)  
Antiguo 15/03/2006, 10:13
Avatar de luistar  
Fecha de Ingreso: marzo-2005
Ubicación: Argentina
Mensajes: 939
Antigüedad: 12 años, 9 meses
Puntos: 0
tienes que verificar que estas enviando todas las variables que te pide el script CGI

vars=POST != 'POST'

:D
__________________
Si digo que soy mentiroso. ¿Lo soy?
  #4 (permalink)  
Antiguo 15/03/2006, 21:34
Avatar de Pablus00  
Fecha de Ingreso: diciembre-2003
Ubicación: A un click de distancia
Mensajes: 1.044
Antigüedad: 14 años
Puntos: 11
Hola Luistar, yo no entiendo bien de esto y perdona si digo una burrada, pero segun entiendo yo, el script lo puedo configurar para enviar infinidad de variables (cada variable corresponde a cada campo), en mi caso hice algunas en html y las recibe perfectamente, el problema ocurre cuando lo paso a un formulario flash. He visto varios modos de envio, por ejemplo loadvars, loadvariables, el que uso yo getURL, en fin, ninguno me anda, yo no se si estoy usando el incorrecto o no, pero me parece muy raro que funcione a la perfeccion en un codigo y en otro no, me podras orientar en lo que hago mal? graxxx
__________________
-- Nunca te des por vencido, aún vencido -- Web
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 02:34.