Foros del Web » Creando para Internet » Flash y Actionscript »

Boton en MC no lleva a Fotograma 1 de escena

Estas en el tema de Boton en MC no lleva a Fotograma 1 de escena en el foro de Flash y Actionscript en Foros del Web. Tengo una escena, con un MC (menu), el cual tiene 5 botones, uno de ellos me debe iniciar la escena. Es decir llevarme al fotograma ...
  #1 (permalink)  
Antiguo 05/10/2006, 16:26
Avatar de Erikzamith  
Fecha de Ingreso: septiembre-2003
Ubicación: Suecia
Mensajes: 75
Antigüedad: 14 años, 3 meses
Puntos: 0
Boton en MC no lleva a Fotograma 1 de escena

Tengo una escena, con un MC (menu), el cual tiene 5 botones, uno de ellos me debe iniciar la escena. Es decir llevarme al fotograma 1 de la escena.

He probado:

1. Colocandole etiqueta al fotograma 1 de la escena (inicio)

on(release){
_root.gotoAndPlay("inicio");
}

2.
on(release){
_root.gotoAndPlay(1);
}

3.
on(release){
_parent._parent.gotoAndPlay(1);
}

4.
on(release){
gotoAndPlay("scene 1", 1);
}

Help!!!
Les agradesco por su pronta respuesta.
__________________
La madre de la invención es la necesidad.
  #2 (permalink)  
Antiguo 05/10/2006, 16:55
Avatar de Avaira  
Fecha de Ingreso: febrero-2005
Mensajes: 103
Antigüedad: 12 años, 9 meses
Puntos: 0
Deberia ir asi pero si no te va eso algo no abras puesto en la explicacion:

on(release){
_parent.gotoAndPlay(1);
}
  #3 (permalink)  
Antiguo 05/10/2006, 16:57
Avatar de Avaira  
Fecha de Ingreso: febrero-2005
Mensajes: 103
Antigüedad: 12 años, 9 meses
Puntos: 0
o tambien si no hay ningun otra escena podria ser...

on(release){
_root.gotoAndPlay(1);
}
  #4 (permalink)  
Antiguo 05/10/2006, 17:15
 
Fecha de Ingreso: septiembre-2006
Mensajes: 1.193
Antigüedad: 11 años, 2 meses
Puntos: 30
on(release){
_root.gotoAndPlay("inicio");
}

asi es como debe ir ahora la pregunta es: debe reproducir desde "inicio" o solo ir y parar por que si solo tiene que ir y detenerse deberia ser

on(release){
_root.gotoAndStop("inicio");
}

Conclusion:
quita el gotoAndPlay y pon el gotoAndStop.
  #5 (permalink)  
Antiguo 06/10/2006, 05:36
Avatar de Erikzamith  
Fecha de Ingreso: septiembre-2003
Ubicación: Suecia
Mensajes: 75
Antigüedad: 14 años, 3 meses
Puntos: 0
Voy a probar

Voy a probar con el gotoandstop(1);
Pero no creo que funcione.

Será que hace falta algo en mi escena, nombrar algo, alguna propiedad.

Espero me funcione.

Gracias por su ayuda...
__________________
La madre de la invención es la necesidad.
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 18:03.