Foros del Web » Creando para Internet » Flash y Actionscript »

Botones dentro de movie clip no funcionan!

Estas en el tema de Botones dentro de movie clip no funcionan! en el foro de Flash y Actionscript en Foros del Web. Hola a todos, se que este es un problema relativamente sencillo, pero nohe encontrado solucion a mi problema especifico, todas las que he encontrado son ...
  #1 (permalink)  
Antiguo 01/09/2008, 09:03
 
Fecha de Ingreso: agosto-2002
Ubicación: Monterrey
Mensajes: 82
Antigüedad: 15 años, 4 meses
Puntos: 0
Botones dentro de movie clip no funcionan!

Hola a todos, se que este es un problema relativamente sencillo, pero nohe encontrado solucion a mi problema especifico, todas las que he encontrado son muy complicadas y el mio realmente no lo es .

A lo que voy es que tengo una pelicula unicamente con un movie clip, es una caja de texto con dos botones, que a su vez puede ser arrastrado con el clasico codigo:

on(press) {
startDrag(this);
}
on(release) {
stopDrag();
}

La cosa es que al meter este codigo dejan de funcionar los botones al interior del movie clip, si se lo quito vuelven a funcionar....
alguna alternativa?.....

cabe mencionar que ya emplee la opcionde convertir los botones a movie clip y ponerles el correspondiente codigo y tampoco funcionó.... parece super simple pero no doy con la formula!... :S

Garcias de antemano!
__________________
Saludos,
Raziel... :)

Última edición por Raziel; 01/09/2008 a las 09:27
  #2 (permalink)  
Antiguo 01/09/2008, 11:12
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Botones dentro de movie clip no funcionan!

Hola Raziel:
Lo que tienes que hacer es colocar un botón en la parte superior que cubra todo el ancho, como una especie del área para un titular y allí coloca el código de arratre del MC.

Espero haberte sido de ayuda.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #3 (permalink)  
Antiguo 01/09/2008, 11:23
 
Fecha de Ingreso: agosto-2002
Ubicación: Monterrey
Mensajes: 82
Antigüedad: 15 años, 4 meses
Puntos: 0
Respuesta: Botones dentro de movie clip no funcionan!

ok ya cree el boton.... al que le puse este codigo:

on(press) {
info.startDrag();
}
on(release) {
info.stopDrag();
}


"info" es la instancia del movie clip

La cosa es: si el boton este abarcatoda el area de mi pelicula si arrastra, pero siguen sin funcionar los botones, ysi lo reduzco de tamaño, como dices, como un titular, deja de funcionar el arraster pero los botones si......

los codigos de mis dos botones dentro del movie clip son:

on (rollOver) {
gotoAndStop(2);

}
on (rollOut) {
gotoAndStop(1);

}

on (release) {
unloadMovieNum(2);
}



--- este es un movie clip

y del otro que si es boton que tiene rollover normal:

on (release) {
getURL("www.google.com", "_blank");
}
__________________
Saludos,
Raziel... :)
  #4 (permalink)  
Antiguo 01/09/2008, 11:38
Avatar de Bandit
Moderador
 
Fecha de Ingreso: julio-2003
Ubicación: Lima - Perú
Mensajes: 16.726
Antigüedad: 14 años, 5 meses
Puntos: 406
Respuesta: Botones dentro de movie clip no funcionan!

Parece que no leíste bien lo que te expliqué.
En ningún momento dije que el botón sea de del tamaño en ancho y alto igual al contenido de tu MC, si lees bien, allí digo que hagas un botón del ancho del área que ocupa, como si fuera una especie de fondo para un titular, o se una franja desde donde se pueda arrastra el MC y podrías pones en ese botón el texto arrastra desde aquí o algo similar.

Espero haberte sido de ayuda y ahora esté más claro.
__________________
Bandit.
Si no sabes estudia y si sabes enseña.
http://www.banditwebdesign.com/
  #5 (permalink)  
Antiguo 01/09/2008, 11:42
 
Fecha de Ingreso: agosto-2002
Ubicación: Monterrey
Mensajes: 82
Antigüedad: 15 años, 4 meses
Puntos: 0
Respuesta: Botones dentro de movie clip no funcionan!

ájala que crees?....

segui sin entender bien tu idea, jajaja perdon, ando lenta hoy, pero me dio la pauta para ocurrirseme poner el mentado boton con las acciones en un layer debajo de mi movie clip y que crees?.... funciona!!!!!!....


si era eso lo que me querias decir sorry por lo despistada, jejejeje!.... :D

Gracias chico, tú si sabes!.....
__________________
Saludos,
Raziel... :)
Atención: Estás leyendo un tema que no tiene actividad desde hace más de 6 MESES, te recomendamos abrir un Nuevo tema en lugar de responder al actual.
Respuesta




La zona horaria es GMT -6. Ahora son las 04:45.